Page 1 of 1

No rSAP connection after flight mode

Posted: Mon Jun 11, 2012 12:09 pm
by general1977
Hello,

during work I have to turn flight mode on. When leaving work I turn flight mode off and leave the building. When approaching the car the phone has established a network connection again and most of the times I even see the SU popup saying "rSAP - SU rights granted". Still the connection to my Mercedes SAPV2 doesn't work. I have to kill the rSAP-App and let it restart itself to be able to connect to the headset. Right now I'm using the app Tasker to do that automatically which works well in most cases.

Is ist possible to add an intent that catches network and BT status and recycle/reset the rSAP app automatically?

I'm using Tytungs NexusHD GB 2.3.7 ROM on my HD2.

Regards
Achim

Re: No rSAP connection after flight mode

Posted: Mon Jun 11, 2012 4:34 pm
by admin
This should all work as you expect. There may be a bug in the software. I'll check that.

Re: No rSAP connection after flight mode

Posted: Tue Jun 19, 2012 11:17 am
by general1977
I have been using Tasker now for a week or so in the manner described above and connection with the Mercedes SAP V2 works flawlessly. When I look at the intents that Rsap catches with the app Autostart Manager, the only intent that odd used is "AT_BOOT". Is that correct?

Regards
Achim

Re: No rSAP connection after flight mode

Posted: Tue Jun 19, 2012 11:31 am
by admin
It is also listening for Bluetooth state, of course. You can watch the status change when you switch Bluetooth on and off.

Re: No rSAP connection after flight mode

Posted: Tue Jul 03, 2012 8:59 pm
by gus8313
Hello,
I have the same problem with my HD2 (android 2.3.7) and my Mercedes SAP V3:
If I switch OFF bluetooth on the HD2(or switch to flight mode), and back ON; I cannot connect the phone to the car, I have to reboot the phone to make it work again.
It seems that if the phone has been connected once to the car, a new connection is impossible if bluetooth has been switched OFF and ON (even if the phone is not connected when switching bluetooth from ON to OFF).
Do you need some traces for investigations?
MfG

Re: No rSAP connection after flight mode

Posted: Thu Jul 05, 2012 10:51 am
by admin
I tried to reproduce the problem but couldn't. Can you please mail me a "main" log? Switch off "rsap" filter so I can see output from the rest of the system.

Re: No rSAP connection after flight mode

Posted: Thu Aug 16, 2012 8:11 am
by Twincharger
I have the same problem with a Galaxy SII, connects only in hands free mode after I switch Bluetooth off and on again, see viewtopic.php?f=32&t=525. Do you want me to send over logs?