It is currently Fri Nov 16, 2018 9:38 am

rSAP for Android Forum

Support forum for Android rSAP App

My RSAP doesn't work anymore

Discussions about running the rSAP app on the HTC HD2 (ex Windows Mobile)
 
Posts: 2
Joined: Fri Sep 14, 2012 8:57 am

My RSAP doesn't work anymore

Post by gkamenov » Fri Sep 14, 2012 9:18 am

Hi all.

I have VW Premium Plus car kit and I use TyphoonCyanogen (now latest) ROM + rsap + bluetooth.apk.

It worked almost year just fine! Recently, my SIM card defeced and I replaced it with new one. Synce then I have troubles to connect the phone with the car kit. One or two times out of a many atempts rsap connected properly, downloaded the phonebook and worked for 5-10 mins. Then the car is saying "Connecting..." and the phone shows "Connected to UHV Premium". It stays in this state until I cancel the atempt on the car kit.
I did: Upgrade ROM to latest version, full reset, even managed to delete all profiles in the car kit while the connection was successfull, installed bluetooth.apk.
The car kit recognises the phone and shows pairing code, the phone popups a prompt for the code, then it connects and status bar shows "Connected to UHV Premium", at the dash of the car the pairing code stay visible (in the past, on this condition it would disapear and would show "Connecting user....".
After restart of the car and the phone, they handshake, phone shows "Connected to..", and the car is showing "Connecting..."

Here are the logs:

Please help!!!

 
Posts: 4089
Joined: Wed Mar 23, 2011 4:12 pm

Re: My RSAP doesn't work anymore

Post by admin » Fri Sep 14, 2012 11:27 am

It's the SIM card. I don't know why, but some SIM cards do not work with rSAP in HTC phones (e.g. some Dutch T-mobile cards). I once received such a card for further tests and it didn't work in any HTC phone, including an old Windows Mobile MDA with factory rSAP support. In Samsung phones the same card worked perfectly.

Now the problem is to get a working SIM card. Perhaps it helps if you ask for a micro SIM card and use an adapter, or your provider understands your problem and has a card from a different manufacturer. I don't know how to tell a bad from a good card so it may be trial and error.

 
Posts: 2
Joined: Fri Sep 14, 2012 8:57 am

Re: My RSAP doesn't work anymore

Post by gkamenov » Sun Sep 16, 2012 12:23 pm

Тhanks!

I already suspected the new SIM card. Fortunately, the provider has several types of SIM cards. Normal with 16K memory, some called "3G" with 64K memory and some others. Mine was 16K and I replaced it with 64K.

Now it works! Almost..

Sometimes the kar kit loses the connection and says: "No paired phone found"", but when I hit "Connect", it reconects again sucessfully. I don't know if this issue is related to RSAP or to something else. It hapened 2-3 times last two days, so I could live with this, but is better to find the reason. Will try new logs and post here.


Return to HTC HD2

Who is online

Users browsing this forum: No registered users and 3 guests