It is currently Fri Nov 16, 2018 2:19 pm

rSAP for Android Forum

Support forum for Android rSAP App

LineageOS 15.1 error

Discussions about rSAP, about this board and whatever is related.
 
Posts: 4
Joined: Fri Oct 12, 2018 5:47 pm

LineageOS 15.1 error

Post by Piet » Fri Oct 12, 2018 6:07 pm

Hello, rSAP worked perfect on my Samsung S4Mini I9195 with LineageOS 14.1.
After upgrading to LOS 15.1 i donT have a SIM-connection. It says: Parameter 'StatusChange' hat nicht den Wert 'CardReset'
qmi_error=QMI_ERR_UIM_NOT_INITIALIZED. When i retry it says: Zeitüberschreitung beim warten auf GET_VERSION (Timeout while waiting for GET_VERSION)
Is there any chance to fix it ?
Thank you, Pete

 
Posts: 4089
Joined: Wed Mar 23, 2011 4:12 pm

Re: LineageOS 15.1 error

Post by admin » Sun Oct 14, 2018 2:26 pm

Can you please create a log with the CatLog app and check if there is some crash inside - or simply mail it to admin at ...

 
Posts: 4
Joined: Fri Oct 12, 2018 5:47 pm

Re: LineageOS 15.1 error

Post by Piet » Wed Oct 17, 2018 10:18 am

Thank you for your answer. I finally managed to create a log. How can i send it to you ? Thank you, Peter

 
Posts: 4089
Joined: Wed Mar 23, 2011 4:12 pm

Re: LineageOS 15.1 error

Post by admin » Sun Oct 21, 2018 1:54 pm

Mail it to admin at android dash rsap dot com - don't want to write it literally, I already get enough spam...

 
Posts: 4089
Joined: Wed Mar 23, 2011 4:12 pm

Re: LineageOS 15.1 error

Post by admin » Fri Oct 26, 2018 7:06 pm

I finally found the time to check your problem. The logs did not reveal anything useful.

I extracted the 14.1 and the 15.1 ROMs and found out that they use a completely different RIL file: the old one uses a Samsung style lib, the new one a Qualcomm style :o

Did you try all possible options for the Qualcomm system files?

 
Posts: 4
Joined: Fri Oct 12, 2018 5:47 pm

Re: LineageOS 15.1 error

Post by Piet » Fri Oct 26, 2018 8:33 pm

Yes i tried all three options.

 
Posts: 4089
Joined: Wed Mar 23, 2011 4:12 pm

Re: LineageOS 15.1 error

Post by admin » Sun Nov 11, 2018 11:52 am

So it looks like the new RIL is not good for rSAP... I don't know why they replaced it. I remember this also happened with another Samsung Galaxy.


Return to rSAP General

Who is online

Users browsing this forum: No registered users and 1 guest