Page 1 of 1

LineageOS 15.1 error

Posted: Fri Oct 12, 2018 6:07 pm
by Piet
Hello, rSAP worked perfect on my Samsung S4Mini I9195 with LineageOS 14.1.
After upgrading to LOS 15.1 i donT have a SIM-connection. It says: Parameter 'StatusChange' hat nicht den Wert 'CardReset'
qmi_error=QMI_ERR_UIM_NOT_INITIALIZED. When i retry it says: Zeit├╝berschreitung beim warten auf GET_VERSION (Timeout while waiting for GET_VERSION)
Is there any chance to fix it ?
Thank you, Pete

Re: LineageOS 15.1 error

Posted: Sun Oct 14, 2018 2:26 pm
by admin
Can you please create a log with the CatLog app and check if there is some crash inside - or simply mail it to admin at ...

Re: LineageOS 15.1 error

Posted: Wed Oct 17, 2018 10:18 am
by Piet
Thank you for your answer. I finally managed to create a log. How can i send it to you ? Thank you, Peter

Re: LineageOS 15.1 error

Posted: Sun Oct 21, 2018 1:54 pm
by admin
Mail it to admin at android dash rsap dot com - don't want to write it literally, I already get enough spam...

Re: LineageOS 15.1 error

Posted: Fri Oct 26, 2018 7:06 pm
by admin
I finally found the time to check your problem. The logs did not reveal anything useful.

I extracted the 14.1 and the 15.1 ROMs and found out that they use a completely different RIL file: the old one uses a Samsung style lib, the new one a Qualcomm style :o

Did you try all possible options for the Qualcomm system files?

Re: LineageOS 15.1 error

Posted: Fri Oct 26, 2018 8:33 pm
by Piet
Yes i tried all three options.

Re: LineageOS 15.1 error

Posted: Sun Nov 11, 2018 11:52 am
by admin
So it looks like the new RIL is not good for rSAP... I don't know why they replaced it. I remember this also happened with another Samsung Galaxy.