It is currently Sun Aug 20, 2017 6:03 am

rSAP for Android Forum

Support forum for Android rSAP App

Test for 64 bit MediaTek

Discussions about rSAP installation
 
Posts: 4022
Joined: Wed Mar 23, 2011 4:12 pm

Test for 64 bit MediaTek

Post by admin » Wed Oct 21, 2015 12:39 pm

This is a test version for phones with the 64 bit MediaTek chipsets, like 6732, 6752, ... and Android >= 5.0.

This version has a major flaw (at least on my UMI Hammer): it doesn't reconnect to the mobile network after an rSAP connection. But that's what the Reconnect plugin is for, isnt't it? viewtopic.php?f=62&t=1115 I'll try to fix this as soon as possible.

Because of SELinux issues you need to use SuperSU, other superuser apps may not work.

The MediaTek phones still won't support the "full" Bluetooth profile, so they will still not work with Porsche PCM, Mercedes SAP V2, new VW Premium, ... See http://www.android-rsap.com/compatibili ... #Bluetooth

Use version 2.5.4+ from Play Store:
https://play.google.com/store/apps/deta ... sapinstall

Any feedback is welcome!

 
Posts: 7
Joined: Wed Oct 21, 2015 9:38 pm

Re: Test for 64 bit MediaTek

Post by elhazard » Wed Oct 21, 2015 9:53 pm

doogee x5 pro (6735) android 5.1

It does not work, sim provider disappears. And in the RSAP program says "System library file not found. Is this ....." not connected with premium vw.

to reconnect with the provider of the sim I have to uninstall the driver


thanks for all... (excuse my English)

 
Posts: 4022
Joined: Wed Mar 23, 2011 4:12 pm

Re: Test for 64 bit MediaTek

Post by admin » Wed Oct 21, 2015 10:44 pm

Strange... This seems to be a 64 bit phone with a 32 bit Android... Can you please verify that you don't have a folder /system/lib64?

I'll update the 32 bit version and upload a new installer. This may take some time.

 
Posts: 7
Joined: Wed Oct 21, 2015 9:38 pm

Re: Test for 64 bit MediaTek

Post by elhazard » Thu Oct 22, 2015 4:57 am

There is no "/system/lib64". Only "/system/lib"

 
Posts: 4022
Joined: Wed Mar 23, 2011 4:12 pm

Re: Test for 64 bit MediaTek

Post by admin » Thu Oct 22, 2015 11:07 am

I updated the installer app in the first post. Now it also contains an updated version for 32 bit Android. Please test it.

 
Posts: 7
Joined: Wed Oct 21, 2015 9:38 pm

Re: Test for 64 bit MediaTek

Post by elhazard » Thu Oct 22, 2015 4:30 pm

much better, but still does not connect me ... "sim State" changes from Normal phone operation to SIM access resquested when I try to connect with the VW UHV Pr. then a message appears in red "System library file not found. Is this a compatible phone?" in a second disappears and appears "Normal phone operation".

In the car's display shows
Connecting ...

in a minute
Unable to connect


thanks for all...

 
Posts: 7
Joined: Wed Oct 21, 2015 9:38 pm

Re: Test for 64 bit MediaTek

Post by elhazard » Thu Oct 22, 2015 4:34 pm

edit
Last edited by elhazard on Mon Oct 26, 2015 1:15 pm, edited 9 times in total.

 
Posts: 4022
Joined: Wed Mar 23, 2011 4:12 pm

Re: Test for 64 bit MediaTek

Post by admin » Thu Oct 22, 2015 5:38 pm

It looks like the RIL demon crashes as soon as the connection is started. I'll try to find out why this happens.

I removed the large post with the log. Please send logs by email (admin at ...)

 
Posts: 4022
Joined: Wed Mar 23, 2011 4:12 pm

Re: Test for 64 bit MediaTek

Post by admin » Thu Oct 22, 2015 6:31 pm

I tested the same installation with an older 32 bit MediaTek and it still works... What happens when you run the SIM check? Can you still make phone calls or does the RIL constantly crash?

 
Posts: 7
Joined: Wed Oct 21, 2015 9:38 pm

Re: Test for 64 bit MediaTek

Post by elhazard » Thu Oct 22, 2015 6:54 pm

Sorry for the log...

With sim check -> exception
Attempt to invoke virtual method 'void com.android_
rsap.rsap.j.h()' on a null object reference.


Phone with calls work fine, no crash


A lot of thanks

Next

Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest