[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4694: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4695: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4696: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
rSAP for Android Forum • View topic - LineageOS 14.1 changed libril (unsupported now)
It is currently Tue Aug 21, 2018 8:24 pm

rSAP for Android Forum

Support forum for Android rSAP App

LineageOS 14.1 changed libril (unsupported now)

Discussions about rSAP installation
 
Posts: 15
Joined: Fri May 15, 2015 1:32 pm

Re: LineageOS 14.1 changed libril (unsupported now)

Post by odoll » Sat Dec 16, 2017 4:00 pm

If I'm not mistaken, when searching for the library /system/vendor/lib/libsec-ril.so, which I couldn't find, in a 'test' I copied libsec-ril.gsm.so as a new file libsec-ril.so to the same directory, but that didn't do the trick. (or maybe I did something wrong (mismatching file properties)?)

 
Posts: 4081
Joined: Wed Mar 23, 2011 4:12 pm

Re: LineageOS 14.1 changed libril (unsupported now)

Post by admin » Mon Dec 18, 2017 12:47 pm

Sorry for the long delay. I just released a version 3.0.6 of the installer app which should fix the problem. It may take a bit until your Play Store app offers the update.

 
Posts: 3
Joined: Fri Dec 08, 2017 2:40 am

Re: LineageOS 14.1 changed libril (unsupported now)

Post by javelinanddart » Mon Dec 18, 2017 8:17 pm

Actually, I'm pretty sure every one of them supports USIM applications, because LTE requires a SIM card as it's a GSM standard.

 
Posts: 15
Joined: Fri May 15, 2015 1:32 pm

Re: LineageOS 14.1 changed libril (unsupported now)

Post by odoll » Wed Dec 20, 2017 6:27 pm


 
Posts: 4081
Joined: Wed Mar 23, 2011 4:12 pm

Re: LineageOS 14.1 changed libril (unsupported now)

Post by admin » Fri Dec 22, 2017 10:21 am

Play Store has a "feature" to start app updates slowly and this is the default. I changed the setting to offer the update to all, you should get it soon.

 
Posts: 15
Joined: Fri May 15, 2015 1:32 pm

Re: LineageOS 14.1 changed libril (unsupported now)

Post by odoll » Fri Dec 22, 2017 10:51 am

np - there's also no lineage-14.1-20171220-nightly-hlte-signed.zip (or later date) this week which would "push" me to an update ;-)
I was just curious as the play store mentioned a change has been made to the app on the 18th however without a change to the available version (number).

 
Posts: 15
Joined: Fri May 15, 2015 1:32 pm

Re: LineageOS 14.1 changed libril (unsupported now)

Post by odoll » Sun Dec 24, 2017 9:33 pm

Meanwhile v3.0.6 arrived and it works (again with e.g. lineage-14.1-20171213-nightly-hlte-signed.zip)

Previous

Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest