Page 2 of 2

Re: LineageOS 14.1 changed libril (unsupported now)

PostPosted: Sat Dec 16, 2017 4:00 pm
by odoll
If I'm not mistaken, when searching for the library /system/vendor/lib/libsec-ril.so, which I couldn't find, in a 'test' I copied libsec-ril.gsm.so as a new file libsec-ril.so to the same directory, but that didn't do the trick. (or maybe I did something wrong (mismatching file properties)?)

Re: LineageOS 14.1 changed libril (unsupported now)

PostPosted: Mon Dec 18, 2017 12:47 pm
by admin
Sorry for the long delay. I just released a version 3.0.6 of the installer app which should fix the problem. It may take a bit until your Play Store app offers the update.

Re: LineageOS 14.1 changed libril (unsupported now)

PostPosted: Mon Dec 18, 2017 8:17 pm
by javelinanddart
Actually, I'm pretty sure every one of them supports USIM applications, because LTE requires a SIM card as it's a GSM standard.

Re: LineageOS 14.1 changed libril (unsupported now)

PostPosted: Wed Dec 20, 2017 6:27 pm
by odoll
admin wrote:I just released a version 3.0.6 of the installer app which should fix the problem. It may take a bit until your Play Store app offers the update.


Would you know how long this might take? As far as I'm concerned the page for the installer app on the play store [1] still says version 3.0.5, but below it mentions "Aktualisiert 18. Dezember 2017".

I removed the app from my mobile and reinstalled it, but it still seems to be the same.

[1] https://play.google.com/store/apps/details?id=com.android_rsap.rsapinstall

Re: LineageOS 14.1 changed libril (unsupported now)

PostPosted: Fri Dec 22, 2017 10:21 am
by admin
Play Store has a "feature" to start app updates slowly and this is the default. I changed the setting to offer the update to all, you should get it soon.

Re: LineageOS 14.1 changed libril (unsupported now)

PostPosted: Fri Dec 22, 2017 10:51 am
by odoll
np - there's also no lineage-14.1-20171220-nightly-hlte-signed.zip (or later date) this week which would "push" me to an update ;-)
I was just curious as the play store mentioned a change has been made to the app on the 18th however without a change to the available version (number).

Re: LineageOS 14.1 changed libril (unsupported now)

PostPosted: Sun Dec 24, 2017 9:33 pm
by odoll
Meanwhile v3.0.6 arrived and it works (again with e.g. lineage-14.1-20171213-nightly-hlte-signed.zip)