problems installing on HTC Legend HBoot1.01/ Remove S-ON

Discussions about rSAP installation
Post Reply
IhaveLegend
Posts: 1
Joined: Wed May 16, 2012 10:13 pm

problems installing on HTC Legend HBoot1.01/ Remove S-ON

Post by IhaveLegend » Wed May 16, 2012 10:22 pm

For anyone who is interested;
I had lots of problems installing Rsap on my HTC legend with HBoot 1.01
during install It said I had the S-On then rebooted in recovery and the phone did nothing anymore.
tried the zip method did not work either, said the zip was wrong.
then I stumbled on to this method of changing S-On to S-Off by updating HBoot to 1.02
without unrooting first!

go this site
www htcdev com / bootloader
but folow this steps :
1.do a nandroid (at least data partition)
2.download the bootloader RUU from HTCdev and run it
3.search for rom.zip in your profile directory (it was extracted from RUU after you had run it)
4.connect the phone to your computer
5.copy that rom.zip to phone's sdcard renaming it to LEGEIMG.zip (mind the case)
6.reboot to bootloader from command prompt (adb reboot bootloader)
7.current bootloader should find the LEGEIMG.zip and ask you to upgrade bootloader
8.after upgrade is done switch to fastboot (use up/down and power buttons)
9.reboot bootloader from command prompt (fastboot reboot-bootloader)
10.at this point you end up in new bootloader which is still locked
11.follow the instructions on HTCdev from Step 8 to unlock

After that you need to boot into recovery, restore data partition and you're back in the saddle.

source: http://forum.xda-developers.com/showthr ... ?t=1579352

coolburner
Posts: 1
Joined: Sat Jun 23, 2012 3:35 pm

Re: problems installing on HTC Legend HBoot1.01/ Remove S-ON

Post by coolburner » Sat Jun 23, 2012 3:37 pm

Hi IHaveLegend,
1.do a nandroid (at least data partition)
means a backup, right? How to do that?

I started with 2. Step, but RUU says:
ERROR[191]: ROM IS NOT SUPPORTED :?

Any ideas ?

Greetz

admin
Site Admin
Posts: 4103
Joined: Wed Mar 23, 2011 4:12 pm

Re: problems installing on HTC Legend HBoot1.01/ Remove S-ON

Post by admin » Sun Jun 24, 2012 10:29 am

You only have to start the RUU, nothing else. Don't press any button or continue to connect the phone etc.

The rom.zip file is usually somewhere below the 'temp' directory. In Windows Explorer you can type '%temp%' in the path field and search from there. This should find the file quicker.

Borph
Posts: 5
Joined: Thu Apr 26, 2012 12:15 pm

Re: problems installing on HTC Legend HBoot1.01/ Remove S-ON

Post by Borph » Sun Dec 02, 2012 5:14 pm

I had the same problems: rsap-install prompted for three options for a Legend (native, generic, special), but didn't succeed anyway because of S-ON. After reboot just got the red triangle. Zip method didn't work either (CM7.2).

Following these instructions the app could finally install successfully, but the VW was in an endless loop with connecting. After choosing "native" instead of "generic" it finally worked!

Post Reply

Return to “Installation”