Cannot install system files (HTC Wildfire S)

Discussions about rSAP installation
Post Reply
bodameco
Posts: 20
Joined: Wed Nov 14, 2012 1:08 am

Cannot install system files (HTC Wildfire S)

Post by bodameco » Wed Nov 14, 2012 1:17 am

Hello all,

I'm having troubles installing the system files in my Wildfire S (Cyanogenmod 10 installed).
The problem is that my phone is S-ON, and for this reason I get the S-ON message.
Then, I click reboot to install them at boot, but I get a full screen picture of the little android robot and an exclamation mark sign.
Giving that the only way to skip this image, and the image itself (with the sign and everything) I can only assume this is an error.

Later on, I reboot my phone, open the installation application again, and the "uninstall" button is active, but I have no network access at all. I can only get network connection after I click the uninstall button.

Is there any way I can install this system files at boot (with a zip file or something)? Or do I really need a S-OFF phone for this?

Thanks a lot

admin
Site Admin
Posts: 4093
Joined: Wed Mar 23, 2011 4:12 pm

Re: Cannot install system files (HTC Wildfire S)

Post by admin » Wed Nov 14, 2012 1:36 pm

The reboot to recovery should do a zip install. If you did this once please check /data/data/com.android_rsap.rsapinstall/files. The rsap_install.zip should be existing there. This can be used with recovery.

But it is strange that you only see the "Android in maintenance mode". This is usually the stock recovery. You get the menu after pressing some button (can't remember which. Power, then volume?), but the install won't work with stock recovery. The ClockworkMod recovery shows the menu immediately.

bodameco
Posts: 20
Joined: Wed Nov 14, 2012 1:08 am

Re: Cannot install system files (HTC Wildfire S)

Post by bodameco » Thu Nov 15, 2012 1:02 am

Ok, I verified the existence of the rsap_install.zip, and it is in fact in /data/data/com.android_rsap.rsapinstall/files.
I copied the file to the sdcard and tried to install it from the recovery menu.

Here I'm getting:

Code: Select all

-- Installing: /sdcard/rsap_install.zip
Finding update package...
Opening update package...
Installing update...
E:Error in /sdcard/rsap_install.zip
(Status 0)
Installation aborted.

admin
Site Admin
Posts: 4093
Joined: Wed Mar 23, 2011 4:12 pm

Re: Cannot install system files (HTC Wildfire S)

Post by admin » Thu Nov 15, 2012 3:27 am

If you did not reboot once more after the failed installation there should be a file with a name like 'lastlog' somewhere in the /cache directory. In it should be more information about what went wrong.

bodameco
Posts: 20
Joined: Wed Nov 14, 2012 1:08 am

Re: Cannot install system files (HTC Wildfire S)

Post by bodameco » Thu Nov 15, 2012 10:43 pm

I got the log file, but I got no hints from it at all.
Please see attached...

Edit: I may have a clue now. I connected the phone to my laptop, and using adb shell I tried to copy the lib to the system directory and unfortunately I got a "no space left on device" error.
The strange thing is that I have RW permissions in this directory and 60Kb free, so a 22Kb file should fit in here...
If this is caused by the S-ON limitation, I think I can't do anything about it :(
Attachments
last_log.zip
(2.25 KiB) Downloaded 126 times

admin
Site Admin
Posts: 4093
Joined: Wed Mar 23, 2011 4:12 pm

Re: Cannot install system files (HTC Wildfire S)

Post by admin » Fri Nov 16, 2012 1:34 pm

Perhaps it is a problem with memory, because usually you can install files in recovery, even if the phone is S-ON. You flashed a custom ROM, so it works! You can reboot to recovery and reconnect via adb and retry. You may have to manually mount system from the recovery menu first.

You may try to find an unnecessary file in /system/lib (/system is a different partition), delete it and retry. The problem is to find an unneeded file there... e.g. libreference-ril.so is not needed, but it is not very large...

bodameco
Posts: 20
Joined: Wed Nov 14, 2012 1:08 am

Re: Cannot install system files (HTC Wildfire S)

Post by bodameco » Wed Nov 28, 2012 3:15 am

Hello,

I finally was able to install rsap system utilities in my wildfire s.
As suspected, the problem was the lack of free space in the system partition.

I spend the last few weeks with a bricked phone because of a patched ROM, but I just got it working. Tomorrow I will test it with the car :)

Thanks

bodameco
Posts: 20
Joined: Wed Nov 14, 2012 1:08 am

Re: Cannot install system files (HTC Wildfire S)

Post by bodameco » Tue Dec 11, 2012 6:44 pm

Hi again,

Just to leave an update for anyone interested:

With Cyanogenmod 10, I was not able to connect the phone to the car kit, and I think it was because of the way the phone is reporting its bluetooth status. On this ROM version, the phone is detected as a "other device".
After installing Cyanogenmod 9, the phone started to be identified as a phone, was detected by the car kit and it's working properly.

Regards

Post Reply

Return to “Installation”