It is currently Mon Nov 19, 2018 3:40 pm

rSAP for Android Forum

Support forum for Android rSAP App

GT-i9001 + Audi MMI + cyanogenmod 9 RC5

Discussions about running the rSAP app on the Samsung Galaxy S
 
Posts: 9
Joined: Wed Dec 26, 2012 12:00 am

GT-i9001 + Audi MMI + cyanogenmod 9 RC5

Post by macavity » Wed Dec 26, 2012 12:18 am

Hi,

after i failed to get an connection with the standard-ROM on my SGS Plus i tryed to install the Cyanogenmod 9 RC5 on my phone. After that i installed the app "Bluetooth SIM Access Install" and after that the app "Bluetooth SIM Access (Trial)"
but it dont work. i tryed it with the SGS III of an friend and it works, so it is not the AUDI MMI.
When i connect both together an answer the questions of the PIN on the Phone and on the MMI, it is connected for about 2 Seconds and then it is diconnected and the MMI gets on the screen for searching a phone.
I have the following LOG an my phone:

12-25 22:09:57.678 E/brcm_patchram_plus(2140): Done setting line discpline
12-25 22:09:57.858 E/BluetoothEventLoop.cpp(242): get_adapter_path: D-Bus error: org.freedesktop.DBus.Error.ServiceUnknown (The name org.bluez was not provided by any .service files)
12-25 22:09:57.878 E/BluetoothEventLoop.cpp(242): get_adapter_path: D-Bus error: org.freedesktop.DBus.Error.ServiceUnknown (The name org.bluez was not provided by any .service files)
12-25 22:09:57.928 E/BluetoothEventLoop.cpp(242): get_adapter_path: D-Bus error: org.bluez.Error.NoSuchAdapter (No such adapter)
12-25 22:09:57.928 E/BluetoothEventLoop.cpp(242): failure setting up Event Loop!
12-25 22:09:58.729 E/BluetoothService.cpp(242): setBluetoothTetheringNative true
12-25 22:09:59.379 E/ (2150): Can't open file for reading
12-25 22:09:59.379 E/ (2150): Can't open file for reading
12-25 22:09:59.460 E/BluetoothMasReceiver(2120): BluetoothMasReceiver onReceive :android.bluetooth.adapter.action.STATE_CHANGED
12-25 22:09:59.470 E/BluetoothMasService(2120): Map Service onCreate
12-25 22:09:59.470 E/BluetoothMasService(2120): Map Service onCreate
12-25 22:09:59.470 E/BluetoothMasService(2120): Starting MAP service
12-25 22:09:59.480 E/BluetoothMasService(2120): Map Service onStartCommand
12-25 22:09:59.480 E/BluetoothMasService(2120): action: android.bluetooth.adapter.action.STATE_CHANGED
12-25 22:09:59.590 E/BluetoothRSAPPhone(2150): java.io.IOException: No such file or directory
12-25 22:10:05.485 E/BluetoothMasService(2120): Handler(): got msg=1
12-25 22:10:05.485 E/BluetoothMasService(2120): Map Service startRfcommSocketListener
12-25 22:10:05.485 E/BluetoothMasService(2120): Map Service initSocket
12-25 22:10:05.485 E/BluetoothMasService(2120): Succeed to create listening socket on channel 16
12-25 22:10:07.267 E/ (2133): Can't open file for reading
12-25 22:10:07.267 E/ (2133): Can't open file for reading
12-25 22:10:47.797 E/GTalkService(410): connectionClosed: no XMPPConnection - That's strange!
12-25 22:10:48.698 E/SIM (455): [SIMRecords] onAllRecordsLoaded: imsi is NULL!
12-25 22:10:49.558 E/TelephonyProvider(455): Failed setting numeric 'null' to the current operator

 
Posts: 4089
Joined: Wed Mar 23, 2011 4:12 pm

Re: GT-i9001 + Audi MMI + cyanogenmod 9 RC5

Post by admin » Wed Dec 26, 2012 1:17 pm

Are you sure your car phone supports rSAP? Usually you start the search from the car and you have to enter a 16-digit Bluetooth PIN on the phone. Did you get a 16-digit PIN when connecting the S III?

If your car phone does not support rSAP it should connect anyway with every ROM using HFP. So I guess there is something basically wrong. Can you pair your phone with some other Bluetooth device, e.g. PC? Are you sure you have a matching ROM for your phone? Some error messages really sound strange.

 
Posts: 9
Joined: Wed Dec 26, 2012 12:00 am

Re: GT-i9001 + Audi MMI + cyanogenmod 9 RC5

Post by macavity » Wed Dec 26, 2012 2:47 pm

Hi, when i pair the phone with the car, on each device i get the question if i would allow the device with the PIN 8 digits to connect, i answer on each device the question with yes, and it is connected ... but only for 2 seconds. Because it was a really hard work to get the custom rom running, maybe there are some libs or files missig, should i try to install the cyanogenmod 10 to my phone? Because the SGS 3 had android 4.1.1 installed, and i have 4.0.4 installed.
Is there a way to check if i have alle the files that i need?

Do you have an idea, with wich software i can try to connect my pc with rsap profile with my phone?

 
Posts: 4089
Joined: Wed Mar 23, 2011 4:12 pm

Re: GT-i9001 + Audi MMI + cyanogenmod 9 RC5

Post by admin » Wed Dec 26, 2012 7:46 pm

When you only confirm an 8 (or 6?) digit code on car and phone you surely cannot run rSAP over this Bluetooth connection. The authentication is not secure enough. For rSAP the car shows a 16-digit code which you have to enter on the phone. For the Handsfree profile it's usually a 4-digit code, I don't know if this is required, but I guess so. Maybe your Bluetooth pairing is only able to handle simpler profiles. So first you should try to create a proper Bluetooth connection. Start the device search in the car.

Double-check if you have the correct CyanogenMod for your phone. Samsung devices having very similar names are completely different! So make sure you have the correct version!

Bluetooth connection should work with any ROM - Samsung and CyanogenMod. If both don't work there's probably something wrong with your phone.

Simply try to pair the phone with a Bluetooth equipped PC. In Windows 7 there is a device search in the Bluetooth settings. Or try to pair with a second phone. In this case the short authentication may be enough.

 
Posts: 9
Joined: Wed Dec 26, 2012 12:00 am

Re: GT-i9001 + Audi MMI + cyanogenmod 9 RC5

Post by macavity » Wed Dec 26, 2012 8:41 pm

I have read the manual about the BT-rSAP-Conn. It is the Quick-Connection mode, therefor i have not to type in the PIN only to confirm on both devices the 6-digit Number, but i can do an normal verifikation and type in an personal PIN in the CAR and confirm this PIN by typing in this on mobile. Maybe this works than. But after i updated my CyanogenMod to Ver. 10 i must try to get my G-Apps installed, this dont work properly, i dont know why, and than i can try this again.

 
Posts: 4089
Joined: Wed Mar 23, 2011 4:12 pm

Re: GT-i9001 + Audi MMI + cyanogenmod 9 RC5

Post by admin » Thu Dec 27, 2012 8:51 am

Is it this adapter viewtopic.php?f=32&t=432&p=2315#p2315?

As far as I know rSAP is only allowed with a 16-digit Bluetooth PIN because of security. Although my app does not necessarily need it I didn't see any car kit with a shorter PIN so far (the later VW devices use ridiculous codes like 1111222233334444) . Usually when you get a shorter code, or only the code confirmation, it is a sign that rSAP is not supported

 
Posts: 9
Joined: Wed Dec 26, 2012 12:00 am

Re: GT-i9001 + Audi MMI + cyanogenmod 9 RC5

Post by macavity » Mon Dec 31, 2012 7:07 pm

Hi, it is a brand new Audi A5 with MMI Plus with "Autotelefon". So there is nothing extra installed in the CAR and it is not possible to connect with an longer 16 Digit code.

 
Posts: 4089
Joined: Wed Mar 23, 2011 4:12 pm

Re: GT-i9001 + Audi MMI + cyanogenmod 9 RC5

Post by admin » Tue Jan 01, 2013 4:10 pm

Audi "Autotelefon" (with WiFi hotspot?) should support rSAP. But I'm still puzzled by the "quick connection". As far as I know you MUST use a 16-digit Bluetooth PIN for pairing. The specification requires it for security reasons. A "weak" pairing may support audio streaming but not rSAP.

You should remove all pairing information in car and phone and then start all over again: make the phone Bluetooth visible, start the search in the car, confirm the device and enter the 16 digit code sbown in the car in the phone. Then rSAP should work.

 
Posts: 9
Joined: Wed Dec 26, 2012 12:00 am

Re: GT-i9001 + Audi MMI + cyanogenmod 9 RC5

Post by macavity » Tue Jan 08, 2013 11:19 am

Hi,
yes it is with WiFi Hotspot. I tryed with an coworker of mine and, with the android 4.1.2 original Samsung S3 it works fine,
also there is only the quick-connection available.

 
Posts: 4089
Joined: Wed Mar 23, 2011 4:12 pm

Re: GT-i9001 + Audi MMI + cyanogenmod 9 RC5

Post by admin » Tue Jan 08, 2013 2:10 pm

Did you watch the rSAP app while pairing the phone? Does it show any status change or error?

I still cannot believe that the simple pairing is possible, but if you tell me so...

Next

Return to Samsung Galaxy S I9000

Who is online

Users browsing this forum: No registered users and 4 guests