It is currently Tue Jan 23, 2018 1:26 pm

rSAP for Android Forum

Support forum for Android rSAP App

App is very unstable and frequently crashes phone

Discussions about running the rSAP app on the Samsung Galaxy S II
 
Posts: 11
Joined: Mon Jun 18, 2012 12:39 pm

Re: App is very unstable and frequently crashes phone

Post by 4r7ur » Thu Jun 28, 2012 12:05 pm

admin wrote:Bought a device ...


WOW! That's dedication 8-) :!:

 
Posts: 4050
Joined: Wed Mar 23, 2011 4:12 pm

Re: App is very unstable and frequently crashes phone

Post by admin » Fri Jul 06, 2012 2:58 pm

Received my SAP adapter and got it working without the rest of an Audi attached ;)

pic1.jpg
Base plate from Audi TT with attached power connector
pic1.jpg (38.11 KiB) Viewed 1398 times

pic2.jpg
Active connection with Galaxy S
pic2.jpg (39.64 KiB) Viewed 1398 times

But sadly (?) rSAP works fine for me. No problems connecting. I got the "B" version, perhaps it is so much different? The version info shows: "Adapter 01.01.00" and "GSM 02.002". It seems you can update the firmware by pluging in a USB stick.

Anyway I'll try to match my working logs against your's. Perhaps I find something.

 
Posts: 11
Joined: Mon Jun 18, 2012 12:39 pm

Re: App is very unstable and frequently crashes phone

Post by 4r7ur » Mon Jul 09, 2012 1:35 pm

admin wrote:But sadly (?) rSAP works fine for me. No problems connecting. I got the "B" version, perhaps it is so much different?


Hmm, I don't really know about the differences between the adapter types. But I know for sure that the one without "B" works as Audi (respectively their supplier) has designed it, since 2 differnet adapters show the same behavior.

Yet I cannot be sure of course that my phone is causing the problem. But android 4.0.3 was installed by a service center, as I've had frequent reboots caused by the famous andoid 2.3.6 version, so they should know how to update a phone properly...

I just sent you a PM.

Kind regards,
Artur

 
Posts: 11
Joined: Mon Jun 18, 2012 12:39 pm

[solved] Re: App is very unstable and frequently crashes pho

Post by 4r7ur » Tue Jan 14, 2014 10:16 am

Things have come to a good end :D

As my phone is out of warranty anyway, I used the recent holidays to get rid of the stock 2.3.4 and installed CM10.2 (nightly from Dec. 17th). As CM doesn't offer rsap, I also installed the rsap app to my S2. And now the app is working perfectly fine, not only with the Audi rsap adapters, but also with the premium phone of a 2013 VW Tiguan. Initially the phonebook access was buggy and only transferred about 10 phone numbers before hanging up, but the BT phonebook app also solved that issue.

The only very minor issue I only sometimes encounter (only) with the Audi adapter is an (automatic) reconnect some minutes after the initial connect - but this really can be neglected.

On my phone the combination of CM10.2 + the rsap app + the bohnebook app provides perfect results :P

Previous

Return to Samsung Galaxy S II I9100

Who is online

Users browsing this forum: No registered users and 1 guest