It is currently Mon Jul 23, 2018 1:53 pm

rSAP for Android Forum

Support forum for Android rSAP App

Firmware 4.1.2 - Samsung rsap not working

Discussions about running the rSAP app on the Samsung Galaxy S II
 
Posts: 4077
Joined: Wed Mar 23, 2011 4:12 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by admin » Mon Jun 03, 2013 7:54 pm

It looks like the switch from normal to rSAP mode does not work or takes far too long. I guess my app shows "SIM access requested..." while trying to connect?

 
Posts: 22
Joined: Tue May 21, 2013 2:46 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by realist42 » Mon Jun 03, 2013 8:32 pm

admin wrote:It looks like the switch from normal to rSAP mode does not work or takes far too long. I guess my app shows "SIM access requested..." while trying to connect?



Hi,

Yes it does, both sides confirm rsap mode, and state 'connected' and then, with in 2-3 seconds the car drop the connection and states 'disconnected' - The phone often thinks it is still connected for a while afterwards. I think this is dead strange as the Handset and the Car has worked in the past, and the only 'new' bit is 4.1.2. It worked with the rsap app with 4.0.3 and the samsung stack with 4.0.4.

Anything else you need me to try? Going away soon, so will only have tomorrow to give you fresh data should you need it.

Regards,

J.

 
Posts: 4077
Joined: Wed Mar 23, 2011 4:12 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by admin » Wed Jun 05, 2013 7:25 am

If it worked before it may be a problem with the radio/baseband software, because the changes in Android are rather small between 4.0 and 4.1. Did you do an official OTA or Kies update? If not, maybe you caught a strange radio software.

 
Posts: 22
Joined: Tue May 21, 2013 2:46 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by realist42 » Wed Jun 05, 2013 4:32 pm

admin wrote:If it worked before it may be a problem with the radio/baseband software, because the changes in Android are rather small between 4.0 and 4.1. Did you do an official OTA or Kies update? If not, maybe you caught a strange radio software.


It the upgrades done to date were all done from a 4.0.4 working with rsap (samsung stack) to 4.1.2 via OTA.
Not sure what else I can try, I could take it back to 4.0.4 again and the upgrade via Kies, could that make a difference?

Regards,

J.

 
Posts: 4077
Joined: Wed Mar 23, 2011 4:12 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by admin » Sat Jun 08, 2013 5:45 pm

I don't think it makes any difference whether you update OTA or with KIES. Maybe you can try to flash a 4.1firmware with ODIN?

 
Posts: 22
Joined: Tue May 21, 2013 2:46 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by realist42 » Tue Jun 11, 2013 10:33 am

admin wrote:I don't think it makes any difference whether you update OTA or with KIES. Maybe you can try to flash a 4.1firmware with ODIN?


Hi,

This is the point where I must confess to be a little lost with Odin and the differences between the PDA packages and others.

What I have done is the following:

1) Working 4.0.4 with Samsung RSAP --> OTA 4.1.2 (rsap not working)

2 ) 4.1.2 (rsap not working) --> Odin PDA package 4.1.2 (same version as I had - rsap not working)

3) 4.1.2 (rsap not working) --> Odin PDA package 4.0.4 (rsap working again)

4) Working 4.0.4 with Samsung RSAP --> OTA 4.1.2 (rsap not working) (Rooted and rsap and phonebook app installed)

... This is where I am today... Is flashing with the PDA package enough, or will I need to flash with all 3 packages with odin (i.e. not just the PDA)?

Any help at this point is appreciated.

Not sure what else to try other than to buy a new phone..
I will need to see if I can find a SGS2 with jelly bean somewhere to see if it really is just my handset that has the issue.

Regards,

J.

 
Posts: 4077
Joined: Wed Mar 23, 2011 4:12 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by admin » Tue Jun 11, 2013 12:45 pm

Usually you flash everything as PDA. If you look inside the md5 (tar) file you see what components are flashed, although the names are not always self-explaining. Where did you get the firmware file from? Samfirmware? I remember I read that 4.1.2 uses a different flash layout and therefore OTA doesn't work, only KIES? I may be wrong...

This is really strange. I don't think it's a generic 4.1.2 problem - someone else would have mentioned that here.

 
Posts: 22
Joined: Tue May 21, 2013 2:46 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by realist42 » Tue Jun 11, 2013 3:37 pm

admin wrote:Usually you flash everything as PDA. If you look inside the md5 (tar) file you see what components are flashed, although the names are not always self-explaining. Where did you get the firmware file from? Samfirmware? I remember I read that 4.1.2 uses a different flash layout and therefore OTA doesn't work, only KIES? I may be wrong...

This is really strange. I don't think it's a generic 4.1.2 problem - someone else would have mentioned that here.


Hi, yup, got it from samfirmware, at it was the same as I had / should have with my version of the handset. I will try and find some time to downgraded it to 4.0.4 again, then look at upgrading it via Kies to 4.1.2. It might work differently, might... Will take me a little while... and I like it with 4.1 on there, so going back to 4.0.4 does not feel tempting.

Handset is out of warranty, so getting Samsung support is not realistic.

It does remind me that I had an issue going from 2.3 --> 4.0.3, where the vibrate function stopped working entirely, as to phone was still under warranty I sent it off. I have no idea what they did to it, but they would have reflashed the unit. Could this be parts of my issue?

Regards,

J.

 
Posts: 4077
Joined: Wed Mar 23, 2011 4:12 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by admin » Wed Jun 12, 2013 7:23 am

One cause of update problems can be the user data. The new version must be able to read the old version's data. This does not always work. Before you spend hours on down- and upgrading you may try to do a full wipe. Backup your data (best to a PC) and/or do a full recovery backup before so you don't lose anything.

 
Posts: 22
Joined: Tue May 21, 2013 2:46 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by realist42 » Wed Jun 12, 2013 10:03 am

admin wrote:One cause of update problems can be the user data. The new version must be able to read the old version's data. This does not always work. Before you spend hours on down- and upgrading you may try to do a full wipe. Backup your data (best to a PC) and/or do a full recovery backup before so you don't lose anything.



Hi,

I wish I had not done that on every upgrade... It would be so handy if I had only just missed something easy and obvious. :cry:

Will do this again, hopefully today.

Regards,

J.

PreviousNext

Return to Samsung Galaxy S II I9100

Who is online

Users browsing this forum: Google [Bot] and 1 guest