PBAP Problem on SGS2 4.0.4

Discussions about PBAP
Post Reply
dannyfiasco
Posts: 7
Joined: Fri Aug 03, 2012 2:49 pm

PBAP Problem on SGS2 4.0.4

Post by dannyfiasco » Fri Aug 03, 2012 2:56 pm

I was using a SGS2 with original Firmware Version 4.0.3 and using the Phone in my car with the MyWay Navigation System. Everything was working fine. I found out, that the car is not using rsap, it is only using PBAP for my understanding. Last Week the Phone was updated to Version 4.0.4 and the car only showed contacts stored on my SIM-Card.
So i decided to install you RSAP implementation and now the car is showing all contacts BUT it is showing one contact for every phone-number. So when a contact has a mobile and a work phone number, the contact will be displayed twice. And i cannot differentiate the contacts.
Normaly i was able to "click" on the contact and the contact-details where shown. Now there seems to be only the one Number in the contact so that the car automatically starts to dial when clicking on the contact.

Any ideas what happend?

Kind regards
Daniel

admin
Site Admin
Posts: 4138
Joined: Wed Mar 23, 2011 4:12 pm

Re: PBAP Problem on SGS2 4.0.4

Post by admin » Sun Aug 05, 2012 1:03 pm

Strange... If you don't need rSAP you should not install my app. Perhaps it helped that you changed anything?

Try to remove pairing information from phone and car and repeat the pairing.

dannyfiasco
Posts: 7
Joined: Fri Aug 03, 2012 2:49 pm

Re: PBAP Problem on SGS2 4.0.4

Post by dannyfiasco » Wed Aug 08, 2012 10:20 am

I read somewhere that sometimes your app also helps to solve problems with pbap. But actually i´m trying to find out what exactly is happening.
Tries to repeat the pairing and everything but now my car shows a single contact for every phone number stored in a contact. I think Samsung changed something in the BT-Stack. I´m trying to find out which files are responsible for the pbap filtering under Android.

I thougt your app changed that not only the SIM-Contacts are shown by the car, but actually i uninstalled your app and now also all contacts are shown, but in the way i mentioned above.

admin
Site Admin
Posts: 4138
Joined: Wed Mar 23, 2011 4:12 pm

Re: PBAP Problem on SGS2 4.0.4

Post by admin » Wed Aug 08, 2012 10:44 am

It looks like there are strange things happening on the 4.0.4 SGS2 :?

Can you please tell me the exact version you are using (XX...)? I'll flash that to my device and check what's happening. I thought everything is fine now because it works so well on the SGS3...

dannyfiasco
Posts: 7
Joined: Fri Aug 03, 2012 2:49 pm

Re: PBAP Problem on SGS2 4.0.4

Post by dannyfiasco » Wed Aug 08, 2012 10:47 am

Actually i´m using XXLQB

admin
Site Admin
Posts: 4138
Joined: Wed Mar 23, 2011 4:12 pm

Re: PBAP Problem on SGS2 4.0.4

Post by admin » Sun Aug 12, 2012 11:59 am

This seems to affect all XXLQx versions of the SGS2 so I created a separate topic here: viewtopic.php?f=32&t=520

Post Reply

Return to “Phone Book Access Protocol”