Page 1 of 1

Strange problem with simcard

Posted: Mon Feb 27, 2012 2:16 pm
by vwpassat
.First of all, sorry for my English, I'm German

I downloaded the trial version of Android rSAP from the market and it worked very well with my MJ2012 VW Passat.
So I bought the app from the market, but then the woes began:
I used the trial version with a different sim (blau.de) and did not suspect that this would have any impact at all.
After having bought the app, I used my original sim (Microsim from base) and it behaved very strangely:
- the connection to the car kit got established, but it took around 2 minutes
- I was never asked to enter my sim pin (which I was asked for during the trial run)
- the car kit woud not connect to the network but at last I can access my phonebook
- BT connection drops after about 3-5 minutes
- when the rsap app is trying to hand the control back over to the phone again, it fails and ends up in an infinite loop forcing me
to reboot the phone since radio won't come up again

I noticed that someone had a similar problem with a Base microsim and so I exchanged the sim for standard sim and this gave me exactly the same result.

I'm quite lost on that, though I know it would not have happened if I used my original sim in the first place...

I'd be grateful for any help.

cheers, vwpassat

Re: Strange problem with simcard

Posted: Tue Feb 28, 2012 11:23 am
by admin
Can you send me a "main" log to my email address? Did you already try to get a different SIM from your provider? I think those problems are caused by the SIM card initialisation. For some reason HTC phones have problems with some cards. Perhaps your provider has cards from a different manufacturer.

Re: Strange problem with simcard

Posted: Tue Feb 28, 2012 11:38 am
by vwpassat
Mail has been sent.
I already changed from the original non-working microsim to a standard sim. The logfile has been generated with the new sim.

Re: Strange problem with simcard

Posted: Tue Feb 28, 2012 10:44 pm
by admin
The problem is that the car sends a command to the SIM card and the card answers with an invalid code. After that the card does not answer any further request. Perhaps it is possible to skip the last command (I don't understand what it's good for anyway...) and give the same answer my card gives.

The problem is that I have to test that. Do you still have the old card? I guess it is no longer possible to make phone calls or cause any other costs, so can you probably mail it to me?

Re: Strange problem with simcard

Posted: Wed Feb 29, 2012 6:10 pm
by vwpassat
I still have the old microsim. Since it has already been deactivated by the provider, it should not be a problem to mail it to you. If it helps to correct the problem, I'll send it to you tomorrow so you should have it on Friday.

Re: Strange problem with simcard

Posted: Sat Mar 03, 2012 5:27 pm
by admin
Thanks for sending me the card. I made a patch and it seems to work!

Now you have to be a bit patient, I have to create a "proper" plugin...

Re: Strange problem with simcard

Posted: Fri Mar 09, 2012 7:15 pm
by vwpassat
Any update on the issue yet?

Re: Strange problem with simcard

Posted: Thu Apr 12, 2012 4:10 pm
by stefanrichard1
According to me it needs a patch or key that you should be received from the store.