It is currently Fri Sep 21, 2018 2:02 pm

rSAP for Android Forum

Support forum for Android rSAP App

Android 4.3 Galaxy S3 I9300XXUGML2

Discussions about running the rSAP app on the Samsung Galaxy S III
 
Posts: 14
Joined: Tue Apr 08, 2014 10:22 am

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Post by sandreuta » Fri Apr 11, 2014 5:48 pm

admin wrote:The HCI logs can be opened with WireShark. I'd appreciate if you mail them to me (admin at ...) cause I always like to know what may go wrong with rSAP, either Samsung or with my app.

If your phone is already rooted you may also check if my app works better with the free trial version.


Hello.
You've got mail with the log attached.
If you could see what's wrong or have any suggestion please post it here.
I will also try out your app and post the feedback. Your app will be very useful to me when I will upgrade my phone because I will probably choose HTC over Samsung's (I' hate the way S5 looks more like a bugdet phone rather than a flagship) native rsap.

 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Post by admin » Sat Apr 12, 2014 3:59 pm

The log does not contain any interesting data. Can you please start logging before you switch on the car and stop after you switch off the car?

 
Posts: 14
Joined: Tue Apr 08, 2014 10:22 am

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Post by sandreuta » Wed Apr 16, 2014 11:33 am

Hello.
I've sent you another log file which I made today.
Maybe this one has any useful info.
Thanks.

 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Post by admin » Wed Apr 16, 2014 12:35 pm

This happens with the built-in Samsung rSAP? The SIM card does not return any useful answer, only weird error codes :shock:
Did you already test my app with the trial version?

 
Posts: 14
Joined: Tue Apr 08, 2014 10:22 am

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Post by sandreuta » Wed Apr 16, 2014 2:21 pm

Yes, this happens with the built-in Samsung rSAP.
The funny thing is that the standard rSAP works only if there are no bluetooth profiles defined on my car. But after creating a profile and disconnecting it fails to reconnect automatically. To make it work again I must connect with an old nokia and then delete both profiles (nokia and samsung) which is a "painful" operation.
I just installed the trial version of your app and after I'll leave my office I will test it in my car.

 
Posts: 3
Joined: Tue Apr 22, 2014 10:20 pm

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Post by acaf.rsap_android » Tue Apr 22, 2014 10:25 pm

I have a similar problem with Samsung's own rSAP. After my S3 was updated to 4.3 Jelly Bean the phone will not connect the first time, ever! What always works is to turn off bluetooth on the phone while it's trying to connect, wait a few seconds, turn it on again, wait that the list of available bluetooth devices pops up on the screen of the S3, and then choose Connect again from my car. It works every time. It seems that the first connection attemp, although not successful puts the phone in an intermediate state that allows the second connection attempt to work.

I hope Samsung will fix it soon, it's really upsetting that Samsung broke something that worked perfectly well and left users without a solution for months.

Cheers
António

 
Posts: 14
Joined: Tue Apr 08, 2014 10:22 am

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Post by sandreuta » Thu Apr 24, 2014 2:44 pm

Hello.
I tested your app and it works ok.
The major downside is that it requires root access.

 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Post by admin » Thu Apr 24, 2014 2:59 pm

I would do without root if it was possible ;)

But it is really strange that Samsung messed up rSAP (again). If it still works with my app, it means that they introduced bugs in the Bluetooth part.

 
Posts: 3
Joined: Tue Apr 22, 2014 10:20 pm

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Post by acaf.rsap_android » Tue Apr 29, 2014 6:47 pm

Let me add that I just upgraded the bluetooth module in my car from the original 2009 novero 5N0035730 B to the new novero 3C8035730 D and everything works again: RSAP now connects flawlessly and the less interesting hands-free connection mode that this new modules also provide also works. Maybe Samsung neglected compatibility with older bluetooth versions.
António

 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Post by admin » Tue Apr 29, 2014 8:18 pm

Weird. If you like you may send me a HCI log with the new Premium box. I'd like to understand what happened...

PreviousNext

Return to Samsung Galaxy S III I9300

Who is online

Users browsing this forum: No registered users and 1 guest