Page 1 of 3

Android 4.3 Galaxy S3 I9300XXUGML2

Posted: Tue Jan 07, 2014 3:48 pm
by nisi70
I got an OTA update on my Galaxy S3 to Android 4.3. Now rSAP is not working anymore. I also deleted profiles in my car and created a new one - no chance. I also rooted and installed rSAP app (trial) - also no luck to connect my phone to the car again. Before, I had Android 4.1.2 and everything worked fine...

Any suggestions?

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Posted: Fri Jan 10, 2014 7:01 pm
by admin
I updated my S3 and there seems to be no difference. Did you remember to reinstall the rSAP system files after the update? What is happening exactly: phone does not connect at all or does it connect shortly and then disconnect?

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Posted: Thu Jan 16, 2014 11:42 pm
by pdcleff
I am having the same problem. Worked fine for a year. Stopped working after my phone software updated to android 4.3. I have a Samsung Galaxy S3, android version 4.3 and 2012 Acura TL. Phonebook will no longer import to my car.

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Posted: Sat Jan 18, 2014 11:14 am
by admin
pdcleff wrote: I have a Samsung Galaxy S3, android version 4.3 and 2012 Acura TL. Phonebook will no longer import to my car.
Please try to remove the phone from the car's Bluetooth settings and redo the pairing, this seems to help most users with the same problem. It looks like this is a special issue for Honda owners, sadly I don't know why it happens.

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Posted: Sat Jan 18, 2014 4:46 pm
by pdcleff
Fixed the phonebook import problem by un-pairing the phone from the car, uninstalling the Bluetooth Phonebook app, reinstalling the Bluetooth Phonebook app, and re-pairing the phone with the car.

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Posted: Mon Jan 20, 2014 8:28 am
by admin
Now I know why the problems happened: the Bluetooth stack changed heavily between 4.1 and 4.3 and my app tried to use the old stack after the firmware update. The update to app version 1.1.6 should fix it.

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Posted: Tue Apr 08, 2014 11:00 am
by sandreuta
Hello, I have the same problem.
After updating to 4.3 form 4.1.2 on my s3 I couldn't get the samsung native rsap to work on my rns510.
I tried different builds (MK6, GNA8) but without success.
When I make a new connection it works without a problem and even syncs the phonebook, but after it doesn't reconnect automatically. It shows "Connecting..." and keeps retrying forever.
The odd thing is that when it firsts connect successfully the gsm signal status bar on the phones doesn't disappear (on 4.1.2 it showed no service which was ok).
I tried the Phonebook trial app, but the same problem persists. I understand that the bluetooth stack changed heavily, but is there a way to work like it used to?
So if anyone knows a 4.3 build for S3 which works with the samsung rsap or have other suggestions please let me know.
Thanks in advance.

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Posted: Thu Apr 10, 2014 9:50 am
by admin
I don't think the changed Bluetooth stack is the reason for your problems. It was only an issue with my app.

Recently I saw a log where the Samsung rSAP obviously sent invalid data over Bluetooth, which caused the car to immediately abort the connection. It looks like there is a bug somewhere in the Samsung firmware. To find out what goes wrong in your case I'd need a HCI log which before Android 4.4 cannot be created without root.

Apart from that I only have the "usual" hints: try another SIM card, remove all SMS from the SIM card (not Android memory!), remove all phonebook or call list entries entries from SIM card (also not Android memory!).

If I find the time I'll try to reproduce the problem with my S3.

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Posted: Fri Apr 11, 2014 2:42 pm
by sandreuta
Hello again.
Firstly, thanks for your reply.
Iplugged the sim card into an old nokia phone and deleted every contact and sms from it, but the same problem occurred when trying to connect.
So I rooted my phone and installed the hci logger. I tried to make a bluetooth connection and the logger captured the data, but I don't know how to read/decode it to make any sense for me.

Offtopic: Yesterday I had a brand new sealed Galaxy S4 Mini GT-I9195 (android 4.2.2) on my desk, so I tried to make a bluetooth connection to my car using it, but it didn't work (same problem as my S3). My SIM card cannot be the problem because if I downgrade my S3 to 4.1.2 (I9300XXEMG4) the bluetooth works flawlessly. Everytime I upgrade/downgrade the firmware I use an old nokia e52 to connect to my car and delete the previous profiles.

Re: Android 4.3 Galaxy S3 I9300XXUGML2

Posted: Fri Apr 11, 2014 4:49 pm
by admin
The HCI logs can be opened with WireShark. I'd appreciate if you mail them to me (admin at ...) cause I always like to know what may go wrong with rSAP, either Samsung or with my app.

If your phone is already rooted you may also check if my app works better with the free trial version.