It is currently Wed Dec 19, 2018 1:35 am

rSAP for Android Forum

Support forum for Android rSAP App

Galaxy S3 mit CM 11 4.4.4

Discussions about running the rSAP app on the Samsung Galaxy S III
 
Posts: 4090
Joined: Wed Mar 23, 2011 4:12 pm

Re: Galaxy S3 mit CM 11 4.4.4

Post by admin » Sun Oct 26, 2014 2:35 pm

Sieht ganz nach diesem Problem aus: viewtopic.php?f=42&t=1229#p7120
Allerdings hatte ich gedacht, dass das keine Probleme mehr bereitet.

 
Posts: 34
Joined: Sun Jul 08, 2012 3:07 pm

Re: Galaxy S3 mit CM 11 4.4.4

Post by chatter » Sun Oct 26, 2014 3:03 pm

Beide Handys gehen an der Nokia 610 FSE
beide Handys gehen an dem SAP V3 Modul nicht!!!
Kann das damit zu tun haben??

LOGS habe ich Dir ja zu gesannt.

Kopplungsvorgang ist ja eigentlich der gleiche oder?

 
Posts: 4090
Joined: Wed Mar 23, 2011 4:12 pm

Re: Galaxy S3 mit CM 11 4.4.4

Post by admin » Mon Oct 27, 2014 12:21 pm

In den HCI Logs war kein Verbindungsversuch vom SAP Modul erkennbar, nur "Bluetooth sichtbar" schalten des Telefons. Bitte nochmal versuchen ein Log aufzuzeichnen, in dem das Telefon zumindest gefunden wird.

Ich kenne leider das SAP Modul zu wenig (mangelnder Mercedes...) und weiß nicht warum die Kommunikation nicht klappt. Ich habe nur inzwischen mitbekommen, dass es sich manchmal schlichtweg weigert mit einem Telefon zu kooperieren, oft tritt das bei Sonys auf. Leider habe ich keine Ahnung woran das liegen könnte, in den Logs sieht aus Telefon-Sicht alles gut aus. Es gibt auch mindestens 2 Firmware-Versionen für das SAP Modul. Vielleicht hilft das Update beim Mercedes Partner?

Das Nokia 610 ist eng verwandt mit dem VW "Premium". Das sind mit weitem Abstand die problemlosesten rSAP-fähigen Telefone. Und ich fürchte sie werden es auch bleiben, da auch die neuen VW Premiums ihre Macken zu haben scheinen.

 
Posts: 34
Joined: Sun Jul 08, 2012 3:07 pm

Re: Galaxy S3 mit CM 11 4.4.4

Post by chatter » Mon Oct 27, 2014 8:19 pm

Was ich heute noch rausgefunden habe ist das das HFP auch nicht funktioniert!
bzw. total rauscht und man nichts versteht...

Denke der Bluetooth Stack ist hier der verursacher!!!

Oder???

SAP V3 ist aktuell habe es selber erst updaten lassen :-)

 
Posts: 4090
Joined: Wed Mar 23, 2011 4:12 pm

Re: Galaxy S3 mit CM 11 4.4.4

Post by admin » Mon Oct 27, 2014 11:14 pm

Da es mit dem Nokia funktioniert, glaube ich eher, dass es am SAP Modul liegt. Da die Probleme erst in letzter Zeit auftreten: vielleicht ist die neue Firmware problematischer als die alte? Vielleicht hilft ein komplettes Rücksetzen des SAP Moduls (Taste länger als 7 Sekunden drücken)?

Eine schlechte Audioqualität über Handsfree ist eher kein Bluetooth Problem. Audio wird digital übertragen. Ich vermute, dass wenn die Bluetooth Verbindung Probleme hätte, würde die ganze Verbindung abbrechen.

Auf jeden Fall bitte nochmal versuchen einen besseren HCI Log aufzuzeichnen. Kam eigentlich schon einmal die Anzeige/Eingabe der 16-stelligen Bluetooth PIN? Das wäre ein interessanter Log...

 
Posts: 34
Joined: Sun Jul 08, 2012 3:07 pm

Re: Galaxy S3 mit CM 11 4.4.4

Post by chatter » Tue Oct 28, 2014 7:47 pm

Der 16 stellige pin wird jedes mal abgefragt und gebe ich auch ein. Deine APP reagiert aber nicht. Im Bluetooth Menü von Android sehe ich das SAP Modul als gekoppelt.
Aber keine Funktion nach ca. 15 sek bricht die Kopplung ab da das Telefon sich nicht meldet so sehe ich das. Wenn es Probleme mit dem Modul gäbe dann wurde er es ja auch nicht finden.

 
Posts: 34
Joined: Sun Jul 08, 2012 3:07 pm

Re: Galaxy S3 mit CM 11 4.4.4

Post by chatter » Tue Oct 28, 2014 7:50 pm

Die letzten logs sind alles mit code Eingabe erstellt worden versuche aber noch ein besseres hin zu bekommen. Bin jetzt auf cm10.2 dort tut hfp problemlos rsap mus ich testen

 
Posts: 4090
Joined: Wed Mar 23, 2011 4:12 pm

Re: Galaxy S3 mit CM 11 4.4.4

Post by admin » Wed Oct 29, 2014 10:19 am

Diesmal war ein Log dabei, in dem das SAP Modul mit dem Handy gekoppelt wurde und anschließend zumindest nach den verfügbaren Profilen gefragt hat, dann aber wieder die Kommunikation eingestellt hat. In den anderen (nicht Nokia) Logs hat das SAP Modul keinen Piep von sich gegeben.

Ich weiß nicht was da schief läuft. Ich habe bereits mehrere Logs mit diesem Verhalten mit "Gut-Fällen" verglichen, und es wurden die selben Daten vom Telefon gesendet. Keine Ahnung warum es einmal funktioniert, das andere Mal aber nicht. Funktioniert es immer noch mit dem Slimkat ROM? Dann würde ich einfach bei dem bleiben...

 
Posts: 34
Joined: Sun Jul 08, 2012 3:07 pm

Re: Galaxy S3 mit CM 11 4.4.4

Post by chatter » Wed Oct 29, 2014 9:09 pm

Slimkat geht, ist ja auch kein cm Basis Rom soweit ich weiß.

S5 lite rom 8.1 geht von Haus aus Basis Samsung rom.

Was meinst du liegt es SAP Modul oder an der cm11
cm10.2 geht auch noch mit dem SAP Modul komisch oder.

Alle anderen Roms die ich versucht habe und nicht auf Basis von cm Rom sind läuft dein App.
auf Basis cm reagiert das Handy immer gleich so das es bis zur Pineingabe kommt und dann geht es nicht weiter und das SAP Modul bricht dann die Kopplung ab.

 
Posts: 4090
Joined: Wed Mar 23, 2011 4:12 pm

Re: Galaxy S3 mit CM 11 4.4.4

Post by admin » Thu Oct 30, 2014 10:09 pm

Ich habe keine Ahnung warum das nicht mit CM11 funktioniert. Es muss irgendetwas in der untersten Schicht von Bluetooth sein, davon verstehe ich leider nicht viel.

PreviousNext

Return to Samsung Galaxy S III I9300

Who is online

Users browsing this forum: No registered users and 1 guest