Page 1 of 3

Android 4.1.1 Jelly Bean

Posted: Fri Aug 31, 2012 10:32 am
by coiae
Hi,
Recently, I updated my Samsung S3 with the firmware "Android 4.1.1 Jelly Bean", so after run rSAP Installation V2.1.3, the bluetooth do not start (try to start and go down inmediatly).
Anybody test "Android 4.1.1 Jelly Bean" with rSAP & SGIII?
Regards

P.D: My cooked rom is "TurkbeyROM JB 4.1.1"

Re: Android 4.1.1 Jelly Bean

Posted: Wed Sep 05, 2012 9:06 am
by admin
I tested the XXDLI1 yesterday and it does not disconnect from the car properly with the original Samsung rSAP. I did not test my app but I guess it will do the same. I hope Samsung will fix that, I really like to have Google Now on my S3!

Re: Android 4.1.1 Jelly Bean

Posted: Wed Sep 05, 2012 2:49 pm
by chris
Hello Admin,

i have a error when i rename the /system/lib/bluez-plugin/sap.so then ist Bluetooth deactivate and i dont can activate.
But i must rename the file to use your app for my 1und1 Handy Sim.

Christian

Re: Android 4.1.1 Jelly Bean

Posted: Wed Sep 05, 2012 4:02 pm
by admin
This is only happening with a leaked Jelly Bean ROM?

Re: Android 4.1.1 Jelly Bean

Posted: Wed Sep 05, 2012 4:23 pm
by chris
Yes this problem is only with a leaked Jelly Bean ROM with 4.0.4 Ice Cream no error.

Christian

Re: Android 4.1.1 Jelly Bean

Posted: Wed Sep 05, 2012 8:33 pm
by admin
I can confirm that. Seems that Bluetooth initialisation now fails when the SAP plugin is missing. I'll check what I can do about that.

I suggest you currently stay with ICS since the leaked JB ROMs seem to have more rSAP related problems.

Re: Android 4.1.1 Jelly Bean

Posted: Sun Sep 16, 2012 11:22 pm
by coiae
Hi,
Finally "everything" is working.
1 st. Install in my SGS3 the JB ROM from the beginning (full wipe)
2 nd. Install from PLAY the Bluetooth SIM Access Profile application (without install Bluetooth SIM Access Install, because JB have native "remote sim" )
And that is...
Everything works with my " Mercedes Bluetooth SAP (V2) cradle" just one "mistake" after the use with bluetooth, don't work re-init the sim and I need to restart the phone.
Regards

Re: Android 4.1.1 Jelly Bean

Posted: Tue Sep 18, 2012 8:13 pm
by admin
I do not recommend to install the rSAP app without installing the system files. But if it works for you... ;)

Re: Android 4.1.1 Jelly Bean

Posted: Wed Sep 26, 2012 10:13 pm
by coiae
Hi,
I installed the rom from the beginning (full wipe) and directly works my Mercedes hands free kit without rsap apk.
But still the same problem... I need to reboot the phone to work again....
Regards

Re: Android 4.1.1 Jelly Bean

Posted: Mon Oct 01, 2012 3:06 pm
by admin
Currently my app does not work properly with the leaked Jelly Bean ROMs. My installation tries to disable Samsung rSAP which kills Bluetooth as a whole. As soon as the official German Jelly Bean is available I'll try to fix that.

But strange that it does not work for you with original Samsung rSAP. I hope they did not spoil it...? It worked so well with 4.0.4!