Galaxy S III and VW Phaeton 2007, please Hellppp

Discussions about running the rSAP app on the Samsung Galaxy S III
Post Reply
Pan67
Posts: 4
Joined: Tue Dec 25, 2012 12:01 am

Galaxy S III and VW Phaeton 2007, please Hellppp

Post by Pan67 » Tue Dec 25, 2012 12:44 am

Hello,
This is my first post here and i hope i can get help here. I am from the Netherlands, so forgive me if my english is not perfect.

My father-in-law has an 2007 Volkswagen Phaeton with build in navigation/radio/cd-changer/phone unit. This is an Rsap unit.

He was using an old Nokia 6230i and that worked just fine.

But... he wanted to enter the world of smartphones and we went off and bought a Samsumg Galaxy S 3 mini. Well.. to be short, that didn't work. I have triep to install the app, but there still was no communication between the car and the phone.

So today we changed the phone to a new Galaxy s3, also because that is listed in the compatibility list.

Straight out the box, it had the following specs;
Model GT-I9300
Android version 4.0.4
Baseband-version I9300XXLEF
Kernelversion 3.0.15-611327-user , SE.infra@sep-71#1 , smp preempt Tue may 22 21:54:17 KST 2012
Buildnummer IMM76D.I9300XXALEF

When i tried to pair it with the Phaeton -> no luck.. "communication error".....

So i updated the phone with Samsungs "KIES", the results are:
Model GT-I9300
Android version 4.1.1
Baseband-version I9300CEDLI1
Kernel-version 3.0.31-256827 , se.infra@SEP-67#1 , smp Preempt Fri sept 28 20:44:37 KST 2012
Buildnummer JRO03C.I9300XXDLIH

After this i tried to pair the car and phone for a happy marriage and....... IT WORKED!!
After entering the safetycode into the phone, it connected and after a couple of seconds the question "VW PHAETON RSAP is requesting acces to SIM" came on the phone..
Answered with "yes" and "don't ask again" and everything seemed ok.

In the display of the car the message "reading phonebook" appeared en the phone was available. You can make calls and receive calls and in the Galaxy S3 there is the message "external Sim active"..

But..... and here is the but....

Only the contacts from the SIM-card are transferred to the car. None of the contacts in the phone's memory are transferred...

On his old Nokia both the contacts from the SIM and the phone where transferred....

I hope that someone can help me to solve this issue...

Because the RSAP is working fine, i am afraid to install the apps mentioned here because i think i will destroy the workin Rsap of the Galaxy.

The question is therefor how to get the contacts from the phone-memory transferred.

Thanks for your reply's!!!!

Greetings and A Merry Christmas to you all !!!
Koen

admin
Site Admin
Posts: 4128
Joined: Wed Mar 23, 2011 4:12 pm

Re: Galaxy S III and VW Phaeton 2007, please Hellppp

Post by admin » Wed Dec 26, 2012 7:22 pm

The older VW Premium phones don't support the now common Phonebook Access Profile (PBAP), but the older IrMC/SYNCH profile. My "Bluetooth Phonebook" app sbould help with phonebook transfer.

Pan67
Posts: 4
Joined: Tue Dec 25, 2012 12:01 am

Re: Galaxy S III and VW Phaeton 2007, please Hellppp

Post by Pan67 » Wed Dec 26, 2012 8:05 pm

Hi,

Thanks for your reply!

I have bought the app this afternoon and installed it succesfully. On the S3 it is shown and the ënable PBAP" and "enable IrMC" ate checked and their state is 'Ready".

Unortunately the Phaeton still only reads the contacts from the sim and none of the contacts from the phone....

The module in the Phaton (on witch you make the connection and you can see the status) is the;
rSap Bedienteil
3D0 035 950
HW: 003
SW: 015
220606 ABB + PC

It is a German Phaeton (my father in law lives in Germany).

I have already resetted the unit in the Phaeton.
I have rebooted the phone.
I have removed the pairing (both from phone and car).
Made the connection again from "scratch"..

But still only the contacts from the sim are transferred...


I realy drives me mad.......... :-)

Any suggestions....????

Greeting,
Koen

admin
Site Admin
Posts: 4128
Joined: Wed Mar 23, 2011 4:12 pm

Re: Galaxy S III and VW Phaeton 2007, please Hellppp

Post by admin » Wed Dec 26, 2012 9:17 pm

If neither IrMC, nor PBAP works I'm at my wit's end. If your phone is rooted you may create a HCI log and send it to me. But this will not necessarily help to get the phonebook synced. I could only check if the car really does not query for IrMC.

Pan67
Posts: 4
Joined: Tue Dec 25, 2012 12:01 am

Re: Galaxy S III and VW Phaeton 2007, please Hellppp

Post by Pan67 » Wed Dec 26, 2012 9:30 pm

Hello,

The strange thing is that his old nokia 6230i transferred all the contacts with no problem.
Both the sim and phone contacts were transferred......... Do you know witch protocol the nokia uses?

The rest workes fine. In the phone there is the message "external sim acces active" ans the signal strenght is shown in the display (behind steering weel). Also all the simcontacts are available and can be scrolled and selected.

The phone is not rooted, so a log will be a problem...

Thnks again.

(He will be in Germany again this weekend, but i am afraid that the VW dealer can't help with this issue also......)

admin
Site Admin
Posts: 4128
Joined: Wed Mar 23, 2011 4:12 pm

Re: Galaxy S III and VW Phaeton 2007, please Hellppp

Post by admin » Thu Dec 27, 2012 2:28 pm

Nokia had a private profile for phonebook transfer which is not easy (impossible?) to implement for Android. The VW dealer will not help you much. He can only check the compatibility list but cannot change the behaviour of the car phone. He may upgrade the Premium box in the car to a newer version, but this is quite expensive.

I still think a 2007 Volkswagen should support IrMC/SYNCH. Since you already tried to connect both devices from scratch there is not much you can do. My phonebook app does not show "connected" for a short time? Can you force phonebook transfer somehow in the car?

Pan67
Posts: 4
Joined: Tue Dec 25, 2012 12:01 am

Re: Galaxy S III and VW Phaeton 2007, please Hellppp

Post by Pan67 » Thu Dec 27, 2012 3:05 pm

Hello,

I will check the state of youre app as soon as the car is here. Now, without connection, the state is "ready".
I will post my findings and further efforts here!

Thanks for the help, the story continues.....:-)

Post Reply

Return to “Samsung Galaxy S III I9300”