Nexus 4 not intialising

Discussions about running the rSAP app on the LG Nexus 4
Post Reply
zadymaq
Posts: 4
Joined: Tue Aug 12, 2014 1:13 pm

Nexus 4 not intialising

Post by zadymaq » Tue Aug 12, 2014 1:19 pm

I need some help because i am having problems getting my phone to work with my car.
I have a VW Passat equipped with the premium bluetooth. I rooted my phone and installed the rsap app, paired successfully with the car using a code/pin that the car system provided and got the connected message on my phone. After this the phone and the display in my car say initialising then it disconnects, then it connects and once again says initialising and it keeps repeating this cycle over and over. I have tried to unpair the phone and tried again but I still get the same message. I am hoping that someone can help me with this as it's driving me nuts.

admin
Site Admin
Posts: 4116
Joined: Wed Mar 23, 2011 4:12 pm

Re: Nexus 4 not intialising

Post by admin » Tue Aug 12, 2014 2:15 pm

Please mail a "main" log to admin at ...
Does the SIM test work?

zadymaq
Posts: 4
Joined: Tue Aug 12, 2014 1:13 pm

Re: Nexus 4 not intialising

Post by zadymaq » Tue Aug 12, 2014 3:37 pm

Hi,

Thanks for your reply. I conducted a sim test in the app and I got a green tick for everything except one field as below:

SELECT EF.ICC (USIM)
USIM class not supported

Next to this there is a yellow triangle with an exclamation mark.

Does this mean anything to you?

admin
Site Admin
Posts: 4116
Joined: Wed Mar 23, 2011 4:12 pm

Re: Nexus 4 not intialising

Post by admin » Tue Aug 12, 2014 4:48 pm

This means that the Nexus 4 doesn't support the "full" SIM mode, but only the GSM mode, see also http://www.android-rsap.com/compatibility.html.
There must be some different problem, a log will show what exactly is happening.

zadymaq
Posts: 4
Joined: Tue Aug 12, 2014 1:13 pm

Re: Nexus 4 not intialising

Post by zadymaq » Tue Aug 12, 2014 10:47 pm

Hi
I'm sorry but being an absolute noob have no idea how to record a log or forward it to you have you got any suggestions?

zadymaq
Posts: 4
Joined: Tue Aug 12, 2014 1:13 pm

Re: Nexus 4 not intialising

Post by zadymaq » Tue Aug 12, 2014 10:57 pm

Sorry I forgot to add that I have enabled logging in the app and I have downloaded and enabled hci logger as well. But further than this I have no idea what to do next.

admin
Site Admin
Posts: 4116
Joined: Wed Mar 23, 2011 4:12 pm

Re: Nexus 4 not intialising

Post by admin » Wed Aug 13, 2014 1:59 pm

It's simple:
  • start "main" log
  • do the connection to the car
  • stop "main" log
  • locate the file in folder "rsap" and mail it to admin at ...
For the last step you may need a file manager app. Usually you can send the file directly from within the file manager. The other option is to connect the phone to your PC and copy the log file from the phone to the PC.

Post Reply

Return to “LG/Google Nexus 4”