Nexus 4 using Cyanogenmod 13 nightly connected, but no net

Discussions about running the rSAP app on the LG Nexus 4
Post Reply
rmeyerz
Posts: 12
Joined: Thu Feb 19, 2015 4:36 pm

Nexus 4 using Cyanogenmod 13 nightly connected, but no net

Post by rmeyerz » Wed Dec 23, 2015 5:17 pm

Hallo,

i just updated my Nexus 4 from Cyanogenmod 12 to 13, nightly Version 23.12.2015. The phone get connected as usual to my premium Phone in my Skoda. But the Car-Phone is not able to connect to any net. I use the gsm-mode, no umts or automatic mode. Trying to change this will get no solutions. When i connect the Nexus 4 without using the rsap profile, everything works fine. But i want to connect in premium mode.

Any idea?

admin
Site Admin
Posts: 4128
Joined: Wed Mar 23, 2011 4:12 pm

Re: Nexus 4 using Cyanogenmod 13 nightly connected, but no n

Post by admin » Thu Dec 24, 2015 12:26 pm

Maybe it is the same problem as here: viewtopic.php?f=42&t=1621 (in German)

Does the phone work at all after the rSAP system files are installed?

rmeyerz
Posts: 12
Joined: Thu Feb 19, 2015 4:36 pm

Re: Nexus 4 using Cyanogenmod 13 nightly connected, but no n

Post by rmeyerz » Fri Dec 25, 2015 11:31 pm

I didn't reinstall the rsap APP. After installing system files as usual after each update of cyanogenmod the phone didn't make Problems. I get a connection to my car in premium mode. But my car is not able to find a provider in GSM mode.

Now I'm back to cm12 and it works. I will try cm13 after Christmas another time.

rmeyerz
Posts: 12
Joined: Thu Feb 19, 2015 4:36 pm

Re: Nexus 4 using Cyanogenmod 13 nightly connected, but no n

Post by rmeyerz » Mon Dec 28, 2015 2:32 pm

So, I updated my Nexus 4 from cyandogenmod 12 to 13 again (Nightly Version 28.12.2015)

I don't think its the same problem as in the other thread.

What i did:
updating to cm 13 with new gapps 6.0 Version
deinstall rsap
reinstall rsap
update Bluetooth system files
delete the Bluetooth connection to my car
reconnect with Bluetooth to my car

The Nexus 4 with cm13 can connect to my car using the premium mode. That's no problem.
But my car didn't connect to any provider, so there is no net. This will happen in all modes (gsm, automatic and umts)
If i change to normal Bluetooth mode, everything works perfect. Also downgrading to cm12 works perfect.

KAB
Posts: 2
Joined: Fri Jan 01, 2016 6:56 pm

Re: Nexus 4 using Cyanogenmod 13 nightly connected, but no n

Post by KAB » Fri Jan 01, 2016 9:23 pm

Hello,
first of all: A happy new year

I've the same problem.
I updated my Nexus 4 from Stock to Cyanogenmod 13 (nightly 2015-01-01). The Nexus can connect to the car in premium mode but the car is unable to connect to a provider. When I try the connect, I get the errormessage "Unable to connect - access denied"

These are the settings I tried (without success):
rSAP-App from the Play-Store
rSAP-App from this thread viewtopic.php?f=42&t=1621
UMTS-, GSM- and Automatic-Mode
Automatic and manual provider selection => when I try "Manual selection", I'll see the different provider (O2, D1, D2). After a short time I get the errormessage "Unable to connect - access denied"

Is there a fix for this problem?

admin
Site Admin
Posts: 4128
Joined: Wed Mar 23, 2011 4:12 pm

Re: Nexus 4 using Cyanogenmod 13 nightly connected, but no n

Post by admin » Sun Jan 03, 2016 1:26 pm

I currently have no idea what may have changed. I guess the baseband software is still the same and the rest should have no influence on the SIM card operation. At least KAB followed the instructions from here http://www.android-rsap.com/faq/107.html#GSMMode, so I'm clueless.

I'll try if I can reproduce this with my Nexus 4.

admin
Site Admin
Posts: 4128
Joined: Wed Mar 23, 2011 4:12 pm

Re: Nexus 4 using Cyanogenmod 13 nightly connected, but no n

Post by admin » Sun Jan 03, 2016 5:58 pm

Got it. Please try the attached installer version.

Use version 2.5.5+ from Play Store:
https://play.google.com/store/apps/deta ... sapinstall

rmeyerz
Posts: 12
Joined: Thu Feb 19, 2015 4:36 pm

Re: Nexus 4 using Cyanogenmod 13 nightly connected, but no n

Post by rmeyerz » Sun Jan 03, 2016 8:54 pm

Thank you very much! This was the solution for this problem. Now I'm able to connect to my provider using the premium mode in my car.

KAB
Posts: 2
Joined: Fri Jan 01, 2016 6:56 pm

Re: Nexus 4 using Cyanogenmod 13 nightly connected, but no n

Post by KAB » Tue Jan 05, 2016 10:17 pm

Herzlichen Dank! Funktioniert wieder einwandfrei!
Klasse Support

Thanks, the connect to the provider will work fine now. Great support :D

Post Reply

Return to “LG/Google Nexus 4”