Does RSAP work on Nexus 4?

Discussions about running the rSAP app on the LG Nexus 4
paul
Posts: 2
Joined: Sat Jun 01, 2013 7:11 pm

Re: Does RSAP work on Nexus 4?

Post by paul » Thu Jun 13, 2013 2:41 pm

Hi,

what I have is: VW RNS510 from 2010, Nexus 4 with CM 10.1-20130612, Android 4.2.2, Installation App V2.3.
what I don't have: RSAP-Connection

When I try to connect via (Search for Phone -> Nexus 4 found - ok) I have to enter the 12-Digit Code. When done, the Nexus shows me "Verbunden mit VW UHV Premium"in it's statusline, but the car says: "Verbindung nicht möglich".

I have a (now) cutted O2-Simcard, which was in use in my HTC HD2 with a full working RSAP-Connection for a long time. Next I tried a T-Mobile Simcard, but result was exactly the same. Using the cutted O2-Card in my HD2 (with adapter), RSAP still works.

The Installation App has the ability to install a different bluetooth.default.so. What is the step by step procedure when I want to try this, eg when should I Install the new lib and how can I deinstall it? Does the installer provide a method to restore the original lib or do I have to do this myself with a filemanager?

Thank you for some hints, how to proceed

dinsx
Posts: 2
Joined: Mon Jun 10, 2013 11:11 pm

Re: Does RSAP work on Nexus 4?

Post by dinsx » Thu Jun 13, 2013 2:58 pm

dinsx wrote:Hi.
I have a Volkswagen Passat of 2008 year with VW Premium Phone. I also have a Nexus 4 with android stock 4.2.2.
My car didn't discover my phone until I rooted the phone and installed your apps (rSAP Installation and rSAP (Trial)).
After run rSAP installation with success and reboot the phone I follow the next steps:

1. Started BT and then rSAP (Trial).
2. Turned on the engine key, and in MFD menu, went to "Phone settings"-"Search"
3. Nexus 4 BT screen showed "VW UHV PREM" !!!
4. MFD display showed "Nexus 4"
5. Enter VW PREM offered passkey (consisting of 16 digits) into the Nexus 4 BT pass field.
6. MFD said "Connecting ..." and after a long time MFD said "Couldn't connect" or "Impossible to connect" or something like so; In the meantime rSAP trial shows that SIM access is taken over and then, when the message about the connection appeared in the MFD, the SIM turn to normal mode.

I have tried rebooting the phone but always the same message.
I have sent you an email with normal and HCI log.

Could you help me?

Thanks and regards.
Do you have any idea regarding this issue?

admin
Site Admin
Posts: 4133
Joined: Wed Mar 23, 2011 4:12 pm

Re: Does RSAP work on Nexus 4?

Post by admin » Fri Jun 14, 2013 9:16 pm

Sorry. You seem to have one of the SIM cards that does not work in a Nexus 4.

Post Reply

Return to “LG/Google Nexus 4”