It is currently Thu Dec 14, 2017 8:03 am

rSAP for Android Forum

Support forum for Android rSAP App

Sony Xperia X Compact (F5321) - Erfahrungen

Discussions about running the rSAP app on Sony Xperia phones
 
Posts: 1
Joined: Wed Nov 22, 2017 10:58 pm

Sony Xperia X Compact (F5321) - Erfahrungen

Post by fl3x » Wed Nov 22, 2017 11:41 pm

Hallo zusammen,

um möglicherweise weitere Suchende wie auch den fleißigen Entwickler selbst zu informieren, anbei folgender Zusammenfassung meiner Aktivitäten rund um die Inbetriebnahme der rSAP-App mit erfolgreicher Remote-Sim-Verbindung zu meinem Audi A4 B9 (MJ2016).

Handy: Sony Xperia X Compact
Standard Firmware: 34.2.A.2.69 (rooted + custom kernel + debloated)
RIL Variante: Qualcomm (64 bit)

Vorgehen zur Installation von rSAP / Qualcomm SIM-Card-Access gemäß:

http://www.android-rsap.com/41-support/ ... ccess.html
http://rsap-xperia-sp.blog.hu/2016/04/1 ... hu-n_58054

1. Set phone's USB to "diag" mode and install drivers for this mode
2. Enable Factory Test Mode with QXDM (necessary!!)
3. Run QPST tool to fix the setting

4. Installation Systemdateien: rSAP Installation App V3.0.5 (Mk. II)
5a. Installation der Trial-App -> funktioniert
5b. Installation der Release-Version -> funktioniert (fast immer)

Einrichten der Verbindung im Auto (im Schnelldurchlauf):

1. Bluetooth und rSAP-App am Handy aktivieren (Optionen "Android 7 Bluetooth Hack" + "aktiv halten" aktiviert)
2. Audi MMI - Werkseinstellungen: "Telefon" + "Bluetooth-Verbindungen" zurücksetzen
3. Datenverbindung aus MMI mit Telefon aufbauen und Option "Autotelefon" wählen (inkl. Kontakte und SMS, Freisprechen deaktiviert)

DONE! Super. Läuft! :D :D

Bleibt nur ein kleiner Wermutstropfen:

Sobald die Verbindung zum Auto einmal aufgebaut wurde (typische Dauer für den Verbindungsaufbau ca. 20-30 Sekunden: Netzsignalanzeige und Datenempfang, z.B. "LTE" wird angezeigt) bleibt die Verbindung sehr stabil bestehen und ich kann problemlos surfen und telefonieren (bisherige max. Testdauer ca. 1 Std. am Stück). Genauso verhält sich der Verbindungsaufbau bei jeder neuen Fahrt in 90% der Fälle: Zündung an, Handy vibriert zur Signalisierung der rSAP-Verbindung, Signalanzeige und Datenempfang bauen sich auf und alles läuft wie oben beschrieben.

Leider kommt es doch noch recht häufig vor, dass zunächst die rSAP-Verbindung (BT) zum Handy aufgebaut wird (Handy vibriert unmittelbar nach Zündung), Signalanzeige im MMI wird vorbereitet (ausgegraut) und die Verbindung bricht unmittelbar wieder zusammen. Nach einiger Zeit (optional mit Anwahl des Telefonmenüs im MMI des Autos) wird ein weiterer Verbindungsversuch initiiert, der dann i.d.R. nach 2-3 Anläufen und wenigen Minuten Geduld auch ohne weitern Eingriff zum Erfolg führt.

Gibt hierzu irgendwelche Erfahrungen, bzw. Ideen wie man diesen Prozess noch stabilisieren könnte? :roll: :?:

Vielen Dank für die tolle App und die Unterstützung im Voraus. :D :D

fl3x

PS: Wie genau funktioniert eigentlich die log-Funktion? Wird das Log aus einem Ringspeicher vergangener Aktivitäten geschrieben oder schreibt die App nach Aktivierung die nächste Session in das Textfile?

 
Posts: 4043
Joined: Wed Mar 23, 2011 4:12 pm

Re: Sony Xperia X Compact (F5321) - Erfahrungen

Post by admin » Sun Dec 10, 2017 11:25 pm

Danke für die ausführliche Beschreibung. Das größte Problem ist ja leider der QPST Prozess, aber zumindest funktioniert er beim Xperia X.

Zum Problem:
Das Loggen ist eine Standard Android Funktion. Es ist in der Tat ein z.T. ziemlich großer Ringspeicher, der dem System und allen Apps zur Verfügung steht. Meine App speichert einfach ihre eigenen Logausgaben in eine Datei.

Ein Log wäre evtl. hilfreich bei der Suche nach dem Grund für die fehlgeschlagenen Verbindungen.


Return to Sony Xperia

Who is online

Users browsing this forum: No registered users and 2 guests