Xperia Z2

Discussions about running the rSAP app on Sony Xperia phones
jorge.ledesma
Posts:3
Joined:Fri Jul 10, 2015 11:21 pm
Re: Xperia Z2

Post by jorge.ledesma » Fri Jul 10, 2015 11:33 pm

Hi

I just recently installed the App on my Z2 Rooted Lollipop 5.02 .

Everything goes fine, except when I try to connect to my Audi Q3 MMI 3G+

When I tried your test app I thought the "Bluetooth Status" was only a placeholder, and that the app did nothing by itself besides running the SIM tests.

I purchased the full app, but the "Bluetooth Status" keeps saying "Not connected" no matter if I connect to the car using the Hands Free Profile.

When I try to connect to the phone as the "Car Phone" after a few seconds the car just shows a "Connection to 'phone' failed". With no change whatsoever in the app.

I'm guessing the app is not really starting all the rsap services in my phone.

BTW, when I run the sim tests I get all greens except on SELECT EF.ECC(GSM) - > File Not Found. But I read somewhere else that this was only the emergency numbers file, and that it shouldn't affect connection to the car.

Please HELP!!

admin
Site Admin
Posts:4139
Joined:Wed Mar 23, 2011 4:12 pm

Re: Xperia Z2

Post by admin » Sat Jul 11, 2015 10:11 pm

Are you really sure your car supports rSAP? Does it have the "Audi connect with car phone" option?

You may create a HCI log and mail it to me (admin at ...). See here how to create a HCI log: http://www.android-rsap.de/41-support/1 ... i-log.html

admin
Site Admin
Posts:4139
Joined:Wed Mar 23, 2011 4:12 pm

Re: Xperia Z2

Post by admin » Tue Jul 14, 2015 2:38 pm

I don't see the car ask for the SIM access profile. Maybe a fresh Bluetooth pairing helps? If you try, please log it! Maybe the car tries once and doesn't try again if something goes wrong, although this is not likely.

Do you have a SIM slot somewhere in the dashboard or glovebox? As far as I know the Audi car phone doesn't come without a SIM slot.

jorge.ledesma
Posts:3
Joined:Fri Jul 10, 2015 11:21 pm

Re: Xperia Z2

Post by jorge.ledesma » Tue Jul 14, 2015 3:03 pm

I'll make sure to log a fresh pairing today.

Thanks for your support.

admin
Site Admin
Posts:4139
Joined:Wed Mar 23, 2011 4:12 pm

Re: Xperia Z2

Post by admin » Wed Jul 15, 2015 1:50 pm

There is still no request for the SIM access profile.

Do you have a SIM slot in your car? Maybe you should verify with an Audi service if your car is supposed to support rSAP.

jorge.ledesma
Posts:3
Joined:Fri Jul 10, 2015 11:21 pm

Re: Xperia Z2

Post by jorge.ledesma » Wed Jul 15, 2015 3:37 pm

Thanks for your help.

I'll take my car to the dealer. It was purchased specifically with the online options. It does not have a sim slot integrated, however I was told that any rsap compatible phone would do the trick.

Post Reply

Return to “Sony Xperia”