XPERIA Z2 5.0.2 ROOTED - RSAP ERROR MESSAGE

Discussions about running the rSAP app on Sony Xperia phones
sunnydude959
Posts: 4
Joined: Mon Apr 06, 2015 5:36 pm

XPERIA Z2 5.0.2 ROOTED - RSAP ERROR MESSAGE

Post by sunnydude959 » Mon Apr 06, 2015 5:42 pm

Hi Guys,

I've got a Sony Xperia Z2 (locked bootloader) with rooted Baltic 5.0.2 firmware (from here: http://forum.xda-developers.com/xperia- ... d-t3057150 )

I'm getting the dreaded "CONNECT_REQ Parameter 'StatusChange' is not 'Card reset' qmi_error = 0x0000" error message. I have read about a similar message on other threads on this forum where people say that the radio/baseband has locked out RSAP access, however their qmi_error is different (their qmi_error=qmi_err_ACCESS_DENIED) - So I wonder if this is something unrelated to my baseband version? RSAP used to work perfectly on 4.4.2

Thanks for your help guys

Sunny.

admin
Site Admin
Posts: 4128
Joined: Wed Mar 23, 2011 4:12 pm

Re: XPERIA Z2 5.0.2 ROOTED - RSAP ERROR MESSAGE

Post by admin » Tue Apr 07, 2015 9:06 am

I have the same problem on my Z3. It doesn't look like the "access denied" problem. I'm working on it and I hope I can find a solution until the end of this week.

GaPhi
Posts: 21
Joined: Thu Apr 09, 2015 9:26 pm

Re: XPERIA Z2 5.0.2 ROOTED - RSAP ERROR MESSAGE

Post by GaPhi » Thu Apr 09, 2015 9:38 pm

Hi,

I have got the same problem on my XPeria Z2 with Lollipop (Downgrade + Root +Recovery + Baltic firmware with inegrated root + Recovery + ByeSELinux patch).
It was working very well with latest Android 4.4.4 + root.

The patch is probably quite simple as the phone loose the network before the rejection (ie, the phone seems to agree some kind of SIM access change and restore it afterward :)).
Of course, I can help you to validate your new version on Z2 phone if you want (I am very frustrated to not be able to connect my car to Internet ! :?)

By the way, I also had difficulties to install the RSAP library : It was automatic with 4.4.4 (if I remember well) and now even the recovery mode was not working (zip is not written on SD card).
I had to search the filesystem for a rsap.zip file, copy it on SDcard and then install it with recovery to have rSAP find the library.
Is it normal or did I miss something in preparing the Z2 with Lollipop like a kind of permission fix ?

Many thanks in advance for your great work ! :P

EDIT : For the automatic installation, we must have R/W access to /system. I use http://forum.xda-developers.com/z3-tabl ... f-t3058400 and now, installation is ok (but still not SIM access).

admin
Site Admin
Posts: 4128
Joined: Wed Mar 23, 2011 4:12 pm

Re: XPERIA Z2 5.0.2 ROOTED - RSAP ERROR MESSAGE

Post by admin » Sat Apr 11, 2015 12:54 pm

Thanks for the link to the "wp_mod" installation. This makes life much easier :D

The first tests suggest that rSAP is still accessible in the baseband software, but I still don't know why the current system files no longer work. I hope this is only a question of time...

Fry
Posts: 1
Joined: Tue Apr 14, 2015 11:17 pm

Re: XPERIA Z2 5.0.2 ROOTED - RSAP ERROR MESSAGE

Post by Fry » Tue Apr 14, 2015 11:46 pm

admin wrote:I hope this is only a question of time...
Any update on this (Z3)? Don't mean to urge, but can you give some kind of rough estimation? Will have to downgrade to KitKat again, but if you manage to get it to work within the next days, I'll spare myself the trouble :-)

Anyway, thanks for your amazing work!

admin
Site Admin
Posts: 4128
Joined: Wed Mar 23, 2011 4:12 pm

Re: XPERIA Z2 5.0.2 ROOTED - RSAP ERROR MESSAGE

Post by admin » Wed Apr 15, 2015 11:27 am

I'd downgrade to KitKat temporarily :oops:
It may take a week or two.

GaPhi
Posts: 21
Joined: Thu Apr 09, 2015 9:26 pm

Re: XPERIA Z2 5.0.2 ROOTED - RSAP ERROR MESSAGE

Post by GaPhi » Wed Apr 15, 2015 12:16 pm

Well, in my case, I will wait 2 more weeks as reconfiguring every application is too long.

I hope your estimation is good ! :-)
And, once more, do not hesitate to ask me some help : I am an embedded software engineer with more than 10 years in cell phone R&D experience...

Staying tuned ! ;-)

admin
Site Admin
Posts: 4128
Joined: Wed Mar 23, 2011 4:12 pm

Re: XPERIA Z2 5.0.2 ROOTED - RSAP ERROR MESSAGE

Post by admin » Sun Apr 19, 2015 2:59 pm

It's working on my Z3, at least so far that I keep running Lolliop from now on. This also puts some pressure on me to make it work better. ;)

I have some reliability problems, installation is missing and it currently works only when the SIM PIN is deactivated. The SIM PIN is currently the biggest problem. I hope I can publish a test version in the next days.

GaPhi
Posts: 21
Joined: Thu Apr 09, 2015 9:26 pm

Re: XPERIA Z2 5.0.2 ROOTED - RSAP ERROR MESSAGE

Post by GaPhi » Sun Apr 19, 2015 3:25 pm

Well done!
As I deactivated the PIN, I am very interested in this version too! :P
Am too excited now! I was afraid to have to downgrade to KK...

GaPhi
Posts: 21
Joined: Thu Apr 09, 2015 9:26 pm

Re: XPERIA Z2 5.0.2 ROOTED - RSAP ERROR MESSAGE

Post by GaPhi » Sun Apr 26, 2015 11:38 am

Hi again!

I finally upgraded from Z2 to Z3,still under Lollipop...
The only app that doesn't work is RSAP now...

Do you have any progress to share with us? Or even better, a very good news?

Thanks!

Post Reply

Return to “Sony Xperia”