It is currently Fri Sep 21, 2018 6:16 am

rSAP for Android Forum

Support forum for Android rSAP App

rSAP and Android 4.3

Discussions about running the rSAP app on the HTC One (m7)
 
Posts: 7
Joined: Fri Oct 04, 2013 11:45 pm

rSAP and Android 4.3

Post by ssilwadi » Fri Oct 04, 2013 11:53 pm

Hello,

Any news regarding rSAP and Android 4.3.

After updating my HTC One from Android 4.1.2 to 4.3, rSAP stopped working. I installed rSAP without rooting by installing the .zip file through the recovery. I did the same with 4.3 but I am getting red font error that the system library file not available.

when you expect to resolve this issue?

Samir

 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: rSAP and Android 4.3

Post by admin » Sat Oct 05, 2013 9:13 am

Did you install a custom recovery? You cannot install the zip file with the stock recovery!

My app should work with a HTC 4.3 ROM, only Audi, Mercedes,... may cause problems (see Bluetooth issues http://www.android-rsap.com/compatibility.html). I hope I can fix that soon.

 
Posts: 7
Joined: Fri Oct 04, 2013 11:45 pm

Re: rSAP and Android 4.3

Post by ssilwadi » Sat Oct 05, 2013 10:05 pm

I have the original 4.1.2 stock ROM that came with the phone and did the system update to 4.3.

I just installed ClockworkMod Recovery to install the zip file and, in the recovery mode, I get a msg that installation of the zip file is successful but rSAP still showing that the system file is missing.

I have a Porsche and rSAP with Android 4.1.2 was working fine. Because of the red error msg, I did not try it in the car.

Samir

 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: rSAP and Android 4.3

Post by admin » Mon Oct 07, 2013 10:36 am

The error message in the app shouldn't happen. It seems something went wrong when installing the zip file. Did you use the one from here: viewtopic.php?f=58&t=817?

The Porsche PCM is partly affected by the Bluetooth problem. If you had the phone paired with your car before the update to 4.3, it should continue to work. But you cannot create a fresh Bluetooth pairing. I hope I can release updated system files in the next days. At least it worked when I tested it on my HTC One.

 
Posts: 25
Joined: Mon Aug 19, 2013 6:45 pm

Re: rSAP and Android 4.3

Post by tomaten » Mon Oct 07, 2013 11:52 am

I have a AOKP 4.3 ROM installed and rSAP works fine. I have only a problem with the phonebook in my Opel. :?

 
Posts: 7
Joined: Fri Oct 04, 2013 11:45 pm

Re: rSAP and Android 4.3

Post by ssilwadi » Tue Oct 08, 2013 8:00 am

Yes, I am using the zip file from the topic you are refering to.

I tried the following:

Uninstalled rSAP app
PowerOff, boot to recovery, install rsap-uninstall.zip and reboot
PowerOff, boot to recovery, install rsap-install.zip and reboot
Install rSAP Installation app
When I run the rSAP Installation app, I get the error:

Sync
Mount -o rw,remount -t ext4/dev/block/mmcblk0p35/system failed

When Install rSAP app I still the same red error

Have no idea what else I can do

Samir

 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: rSAP and Android 4.3

Post by admin » Tue Oct 08, 2013 6:47 pm

I also had problems with ClockworkMod recovery. The only recovery that works for me is PhilZ http://forum.xda-developers.com/showthr ... ?t=2201860. Choose the correct one for your phone.

 
Posts: 7
Joined: Fri Oct 04, 2013 11:45 pm

Re: rSAP and Android 4.3

Post by ssilwadi » Tue Oct 08, 2013 7:03 pm

I will try it. But CWM recovery worked for me on 4.1.2 version

 
Posts: 7
Joined: Fri Oct 04, 2013 11:45 pm

Re: rSAP and Android 4.3

Post by ssilwadi » Sun Oct 13, 2013 7:28 am

I tried that recovery. Same problem.

Samir

 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: rSAP and Android 4.3

Post by admin » Mon Oct 14, 2013 7:14 am

I just tested it once more with 4.3 on my HTC One and it works fine for me. I have no idea why it doesn't work for you. You need not run the installer app after installing the zip file in recovery, but it doesn't hurt. Can you please check if there are error messages when installing the zip file in recovery? Maybe the zip file wasn't downloaded properly (viewtopic.php?f=58&t=817)?

Next

Return to HTC One

Who is online

Users browsing this forum: No registered users and 1 guest