It is currently Mon Sep 24, 2018 10:11 am

rSAP for Android Forum

Support forum for Android rSAP App

HTC One (M8)

Discussions about running the rSAP app on the HTC One (m7)
 
Posts: 2
Joined: Tue Jan 20, 2015 2:38 pm

Re: HTC One (M8)

Post by doubledrat » Tue Jan 20, 2015 4:25 pm

doubledrat wrote:I've just updated to CM12 on my one M8 and rSAP has stopped working. It says "system library file not found". I've reinstalled it and the companion app and done so through recovery, but still no joy. any ideas?


forget it. I've got it working. I did the same as above but in a different order and now it works. For anyone else's benefit, what worked was -

uninstall rsap
uninstall Bluetooth sim access install
install Bluetooth sim access install via recovery
install rsap

 
Posts: 14
Joined: Tue Apr 08, 2014 10:22 am

Re: HTC One (M8)

Post by sandreuta » Tue Jan 20, 2015 5:09 pm

proddick wrote:Has anyone with an unlocked HTC One (M8) tested the new Android 5.0 build (1.14.2015) to see if RSAP is still present?

http://www.htc.com/us/support/htc-one-m8/news/

I am finding my Nexus 5 unreliable with the old radio firmware under the newer versions of Android and am thinking of changing phone, but am looking for something that will work under 5.0


HTC One M8x (Taiwan), software version 4.16.709.9 - Andoid 5.0.1 -> native rSAP works like a charm. I think it connects to my car even faster than before.

 
Posts: 7
Joined: Mon Mar 02, 2015 10:02 pm

Re: HTC One (M8)

Post by nosferatu » Mon Mar 02, 2015 10:05 pm

Hi,
unfortunately HTC M8 does not work neither with native nor with Rsap App support on Lollipop 5.0.1 with Firmware 4.16.401.10.

Any suggestions?

Regards
Marcel

 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: HTC One (M8)

Post by admin » Wed Mar 04, 2015 8:11 am

What exactly does not work? Pairing? Connects but immediately disconnects? Phonebook?

 
Posts: 7
Joined: Mon Mar 02, 2015 10:02 pm

Re: HTC One (M8)

Post by nosferatu » Wed Mar 04, 2015 9:34 am

Pairing does not work with Mercedes SAPV3 and HTC M8. The BT PIN is entered, is accepted by M8 somehow, but the positive acceptance tone from the car does not appear.

So pairing in phone is done as seen in BT settings, but not in the car.

With M7 and Lollipop 5.0.2 and your Software it is working fine.

 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: HTC One (M8)

Post by admin » Wed Mar 04, 2015 7:46 pm

For me it looks like the SAP V3 has problems with more than one paired phone. At least I experienced the same while doing a few tests with the V3 and I couldn't find a reason for that. If you want you can mail me a "HCI Snoop" log (admin at ...), maybe this time I find the reason for the failed connection. Start the log in the Android settings developer menu before you power on the car and don't forget to stop it before sending the file.

 
Posts: 7
Joined: Mon Mar 02, 2015 10:02 pm

Re: HTC One (M8)

Post by nosferatu » Fri Mar 06, 2015 3:14 pm

will start logging today.

 
Posts: 7
Joined: Mon Mar 02, 2015 10:02 pm

Re: HTC One (M8)

Post by nosferatu » Mon Mar 09, 2015 2:56 pm

Hi,

logging files send to admin @ android - rsap . com

 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: HTC One (M8)

Post by admin » Tue Mar 10, 2015 10:09 am

As expected: the SAP module queries for the SIM access profile, gets an answer from the phone and then does nothing, nada, nichts. The only possibly strange thing is that the phone reports the SIM access profile twice. I don't know if that's the reason for the following silence.

In case your m8 is already rooted you may try my app. If this still doesn't work please mail me another log.

Maybe it helps to simply reset the SAP module to factory settings and try again.

 
Posts: 7
Joined: Mon Mar 02, 2015 10:02 pm

Re: HTC One (M8)

Post by nosferatu » Wed Mar 11, 2015 12:41 pm

Hi,

same behaviour with or without your app.

PreviousNext

Return to HTC One

Who is online

Users browsing this forum: No registered users and 1 guest