It is currently Sun Jul 22, 2018 4:29 pm

rSAP for Android Forum

Support forum for Android rSAP App

Rsap causing loss of network connection

Discussions about running the rSAP app on the HTC One (m7)
 
Posts: 1
Joined: Sun Jul 20, 2014 3:23 pm

Rsap causing loss of network connection

Post by aneesh99 » Sun Jul 20, 2014 3:30 pm

Hi all,

So I've been trying in vain to get my M7 to work with my new A6. I'm having an issue where it all connects to the car in data phone mode but as soon as it connect, my phone loses it's network connection. When I disconnect, it reconnects to the network (Vodafone UK)...

When I run a sim test via the app, first it disconnects from the network and the test says CONNECT_REQ - TImeout waiting for STATUS_IND, and if I back out and rerun it with again (still with no connection), the test runs sucessfully. Closing the app completely results in the 'preparing sim card' message where upon it re-establishes a connection to the network.

 
Posts: 4077
Joined: Wed Mar 23, 2011 4:12 pm

Re: Rsap causing loss of network connection

Post by admin » Mon Jul 21, 2014 7:34 am

It is by design that the mobile phone loses network connection while rSAP is active, because it no longer "owns" the SIM card, so it cannot connect to the mobile network.

I found out that the timeout for a connection in the SIM test is rather short. It's also possible that the phone gets confused when the SIM test times out. I'll change that in the next version.


Return to HTC One

Who is online

Users browsing this forum: No registered users and 1 guest