Page 1 of 1

Issue with releasing the connection

Posted: Fri Sep 13, 2013 7:28 pm
by betelgeuse
Hi

I have a Skoda Superb 2010 and have successfully connected my Galaxy S4 running CyanogenMod 10.2 (Android 4.3) through rSAP. But when I leave the car the connection is not released and therefore the phone has no contact with SIM card, and I cannot receive or make calls. Enabling/disabling flight mode does not help - I have to reboot my phone. Reconnecting is also not possible before reboot is performed. I have XXUBMF8 baseband version.
This issue has been present in all CyanogenMod releases since I bought the app (late august)

Is this something you can investigate and remediate?

Regards.

Re: Issue with releasing the connection

Posted: Sat Sep 14, 2013 9:49 am
by admin
I sadly don't know why this happens, this haunts me from the beginning on Samsung phones. It seems to be related to the SIM card, because I never experienced it on my phones. I guess it didn't happen with the Samsung firmware?

Can you check if it fixes the problem when you touch "install/update" in the installer app? This restarts the interface between Android and the radio/baseband/modem software.

Re: Issue with releasing the connection

Posted: Mon Sep 16, 2013 8:51 am
by betelgeuse
Thank you for your feedback.

Did some testing yesterday, and of course I did not experience the issue at first. Two hour long drives and no problem. Seems this only occurs for short trips, taking the kids to kindergarden or driving to the store. These trips only take 2-3 minutes (yes I am lazy), but it seems that the connection between phone and car have not been properly initiated before I turn off the ignition.

Then finally, I took a half an hour drive and made a phonecall while connected, and when I returned home, the phone had to be rebooted. I tried to update the BT drivers, disable/enable the rSAP service and even uninstall/reinstall BT drivers, but nothing worked.

This annoys me, but furtunately the reboot takes less than a minute with CyanogenMod :)

I have not tested with Samsung firmware, so I am unable to comment if issue was present there as well.

Re: Issue with releasing the connection

Posted: Tue Jan 28, 2014 6:20 pm
by mula
This happens also on my s4 running original samsung Firmware

Re: Issue with releasing the connection

Posted: Thu Jan 30, 2014 8:38 pm
by admin
Please try if this plugin helps: viewtopic.php?f=62&t=1115