It is currently Fri Sep 21, 2018 7:49 pm

rSAP for Android Forum

Support forum for Android rSAP App

version 4.4.2 (kitkat)

Discussions about running the rSAP app on the Samsung Galaxy S IV
 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: version 4.4.2 (kitkat)

Post by admin » Mon Mar 31, 2014 11:17 am

Starting with Android 4.4 there is an option "Bluetooth HCI Snoop" in the developer settings. This does not require root access.

 
Posts: 6
Joined: Sun Mar 30, 2014 9:59 pm

Re: version 4.4.2 (kitkat)

Post by w123 » Mon Mar 31, 2014 12:41 pm

admin wrote:Starting with Android 4.4 there is an option "Bluetooth HCI Snoop" in the developer settings. This does not require root access.


Got it!, thanks!, will try within today and add the files here, just in case there's an easy way of having rsap working, I hope it helps for the rest of the people that have this issue...I guess the log is automatically stored somewhere in the internal memory of the S4, isn't it?

I've tried turning on bluetooth in the car and connecting it, but I can't find where the file is saved, there isn't any folder called "rsap"

Thanks!:)

 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: version 4.4.2 (kitkat)

Post by admin » Tue Apr 01, 2014 2:18 pm

The file is usually named btsnoop_hci.log and resides in the root directory of SD card/USB memory.

 
Posts: 6
Joined: Sun Mar 30, 2014 9:59 pm

Re: version 4.4.2 (kitkat)

Post by w123 » Tue Apr 01, 2014 5:19 pm

Thanks! I found it, I had two files one named as .log and one as log.old... I hope these file can clarify why the VW bluetooth can't connect in this case... I've sent it to admin's email, as suggested... I'm not sure it it's the correct file...one of them siez is 32 mb :o

Thanks! :D

 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: version 4.4.2 (kitkat)

Post by admin » Tue Apr 01, 2014 8:07 pm

The 'old' file contained an rSAP session, the other file probably contains audio, that's why it's so huge...

It looks like there is a problem in the Bluetooth handling. The WireShark tool shows that the phone sends 'malformed packets', then the car aborts the connection. So maybe my app does better because it doesn't use the Bluetooth stuff of Samsung rSAP, but that's guessing. It's also strange that changing the SIM card influences Bluetooth, but in software everything is possible :roll:

You have to decide if you want to give my app a try - it needs root access. Rooting or installing my app will not delete any data, but you'll lose warranty and there is a (very small) chance that something goes wrong while rooting.

Another possibility is to get a new SIM card from the provider. You should try to get a different card, from a different batch and/or manufacturer. Of course, if your current card is not very old, chances are high that a new card has the same problem. But it's worth a try.

 
Posts: 6
Joined: Sun Mar 30, 2014 9:59 pm

Re: version 4.4.2 (kitkat)

Post by w123 » Wed Apr 02, 2014 12:29 am

I'll try with other sim from the same company, but these one is new, from this last month... could have something to do with this, that my phone company uses his own coverage and also a second one from other company, when its own coverage is not avaliable? I've been asking, and looks like companies that has its own coverage works well, the ones that hires the coverage to other company, are the ones with this issue.

I would want to avoid rooting, to avoid knox, and so... because of the warranty, at the end my bluetooth is able to work also without Rsap...

Anyway I'll continue checking with other sim cards and phone companies, in case we can identify a pattern, as far as I've tried with the same bluetooth, same phone, and same android version, changing only the sim card is when I get rsap working, or not...

Thanks for your help! As I said, I'll try to check and come back with as much info as I can get...

 
Posts: 4082
Joined: Wed Mar 23, 2011 4:12 pm

Re: version 4.4.2 (kitkat)

Post by admin » Wed Apr 02, 2014 7:30 am

I don't think you'll find a pattern. I guess it is one of the countless little differences between different SIM cards which causes the Samsung rSAP to send crap data. It's most probably a bug in Samsung software. After all the card works fine in normal phone mode, doesn't it?

 
Posts: 6
Joined: Sun Mar 30, 2014 9:59 pm

Re: version 4.4.2 (kitkat)

Post by w123 » Wed Apr 02, 2014 9:19 am

The only pattern I can find is with sim cards from phone companies that hires the network to other company, I've asked and most of the times in this case, it doesn't work...

I've been asking Samsung, and they said I should ask VW, phone company sais the sim card is correct, the only change made is the sim card... I hope with next update it star working properly, as it used to do...

Yes, the sim works OK, only issue I've found is with Rsap in the VW... :( it works well even the LTE...

Previous

Return to Samsung Galaxy S IV I9505

Who is online

Users browsing this forum: No registered users and 2 guests