Page 1 of 4

Galaxy S4 not supported by my rSAP app - now supported!

Posted: Fri May 03, 2013 8:39 am
by admin
Currently I think that the Galaxy S4 should support rSAP and PBAP without my apps. If you find any serious problems I may consider to buy one and try to port my apps. Until then I'm very happy with my HTC One :D

UPDATE: Phonebook app is compatible starting with version 1.1.1

UPDATE: my rSAP app is supported with installer app 2.4 or later. I still don't think it works better than the built-in rSAP, but you may try.

Re: Galaxy S4 not supported by may apps!

Posted: Mon May 06, 2013 9:26 am
by Papirespapi
Hi. I have just bought a GT-I9500 yesterday

I have tried to pair it with my VW RNS510 bluetooth. I get the same problem as the others. The car detects the phone, ask me to key in the code given by the car, ask me to allow the connection to the SIM and then will give me an error message after a few seconds. The error message is "Phone not compatible".

I have have successfully rooted the Galaxy S4 and installed the RSAP app => Same result

I have tried to installed the modified lib on the RSAP installation APP. =>I get an error message saying:
"Deinstallation failed. MV/system/lib/hw/bluetooth.defaut.so.orig failed failed on '/system/lib/hw/bluetooth/defaut.so' - No such file or directory

For your information, I have been using several phones with the same SIM with my VW RNS510. All were working fine and the latest phone I was using was the Galaxy S2. Any ideas. Thanks in anticipation for assistance

Re: Galaxy S4 not supported by may apps!

Posted: Mon May 06, 2013 4:30 pm
by Misiektt
Finally someone with the same problem but I dont get phone incompatible message maybyi have older firmware

Re: Galaxy S4 not supported by may apps!

Posted: Mon May 06, 2013 8:24 pm
by admin
I made a short test with my new S4 (Build JDQ39_I9505XXUAMDM) and everything works fine with my VW Golf. No aborts, not even when receiving an SMS, all phone contacts transferred. Perhaps the S4 is more picky with SIM cards?

Re: Galaxy S4 not supported by may apps!

Posted: Mon May 06, 2013 8:28 pm
by admin
Papirespapi wrote:Hi. I have just bought a GT-I9500 yesterday
Is it an I9500 or an I9505? I thought the I9500 is not yet available?

Re: Galaxy S4 not supported by my apps!

Posted: Tue May 07, 2013 11:48 am
by texdo
Depends on the market. In Russia the official sales started only for 9500 model.

Re: Galaxy S4 not supported by my apps!

Posted: Tue May 07, 2013 12:52 pm
by admin
Maybe it is a I9500 problem? If you look at the ROM dumps: it is a completely different system so it may behave differently. The other poster with problems didn't explicitly mention which model they have.

Re: Galaxy S4 not supported by my apps!

Posted: Wed May 08, 2013 8:25 am
by terje.tel
I just want to add that the "Bluetooth Phonebook" App works wonders on my I9505 as the original implementation always crashed the phone in my car. VW CC '09

However, I would love if you added some kind of option to select with groups of contacts are actually synced to the car?

//Terje

Re: Galaxy S4 not supported by my apps!

Posted: Wed May 08, 2013 6:38 pm
by admin
So there are still bugs in the S4 phonebook transfer...
My app helps because it disables the built-in phonebook transfer. Sadly it cannot start my implementation :roll:
I hope I can fix that.

Re: Galaxy S4 not supported by my apps!

Posted: Thu May 09, 2013 5:56 pm
by terje.tel
So what you mean is that when I don't allow PBAP from the built in support, it cannot use your App for that? I did notice in you App that IrMC was used? If you need some help testing something, just email me directly. However I don't intent to root my S4.

How about that wish for contact filtering? :)