[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4694: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4695: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4696: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
rSAP for Android Forum • View topic - Google Nexus 5 and Mercedes SAPv3
It is currently Tue Aug 14, 2018 8:44 am

rSAP for Android Forum

Support forum for Android rSAP App

Google Nexus 5 and Mercedes SAPv3

Discussions about running the rSAP app on the LG Nexus 5
 
Posts: 30
Joined: Mon Jun 06, 2011 10:10 pm

Google Nexus 5 and Mercedes SAPv3

Post by Quentin » Wed Nov 06, 2013 2:00 pm

Hi.

I thought I open a thread for this. Seems I am one of the first to have a Nexus 5 and being able to test rSAP on 4.4.

As I told you in the Mercedes forum: in difference to Android 4.3 and Galaxy Nexus now I was able to pair, but the connect failed afterwards.

I used now the new installer from the information thread in this forum. This brought a bit progress: my car now asked for the PIN to access the SIM. But afterwards, nothing more happens.
The car acts as if it is connected (but has no reception - and if you try to dial, it says it is not connected) while rSAP on the phone says it is connected to the car and mobile network is off.

I can pull a log this evening on the way back from work...

Best regards,
Quentin

 
Posts: 8
Joined: Tue Mar 12, 2013 6:20 pm

Re: Google Nexus 5 and Mercedes SAPv3

Post by harp » Wed Nov 06, 2013 2:14 pm

For my VW UHV Premium i can say the market version had the same problem you descriped.
The version from information thread worked just fine on a quick test this morning.

But it might be possible that it is not working stable yet?!

Will test again tomorrow on a longer ride.

 
Posts: 4081
Joined: Wed Mar 23, 2011 4:12 pm

Re: Google Nexus 5 and Mercedes SAPv3

Post by admin » Wed Nov 06, 2013 2:57 pm

So far I tested with the Audi SAP adapter and the VW Premium. The only thing that was strange was that the VW did not show the provider name, but all else worked. Maybe some files on the SIM card don't work like they should?

 
Posts: 30
Joined: Mon Jun 06, 2011 10:10 pm

Re: Google Nexus 5 and Mercedes SAPv3

Post by Quentin » Wed Nov 06, 2013 4:30 pm

You mean I should go for a different SIM card?

According to my car's output it is "not connected". Seems not 100% is covered that was covered before. I will pull a log later. Maybe we find the issue :)

Best regards,
Quentin

 
Posts: 4081
Joined: Wed Mar 23, 2011 4:12 pm

Re: Google Nexus 5 and Mercedes SAPv3

Post by admin » Thu Nov 07, 2013 8:34 am

I must confess that I did not yet analyze what's happening under the hood, because it worked for me. It may as well be that the Nexus 5 software hides some SIM card files from the car for whatever reason, but that's wild guessing. It's only strange that I didn't get an operator display in my car and you have a somehow related problem.

A log would help to find out what's really happening.

 
Posts: 30
Joined: Mon Jun 06, 2011 10:10 pm

Re: Google Nexus 5 and Mercedes SAPv3

Post by Quentin » Thu Nov 07, 2013 3:57 pm

I have some curious story now. Yesterday I arrived at my car after work. I turned on HCI log, MAIN log, prepared to catch the failing connect.

And what happend? It connected right away... 100%... I could see provider, signal... it worked.

I tried it again this morning: it connected again immediately. I have no idea why it didn't earlier (and yes, I had rebooted my phone after the new install)...

But now it works like it did with my Galaxy Nexus with 4.2 or earlier. I am happy so far. I will dare to turn off all logging later and hope it still works :D :D :D

@Admin: come on, man - give me a freakin' mail address to donate via Paypal to. I had my fun over 2 years with your app - I cannot buy it again and you helped me over and over again over now 2 devices. Am I the first one to beg to acutally GIVE away money? :D

Best regards,
Quentin

 
Posts: 6
Joined: Wed Oct 31, 2012 4:21 pm

Re: Google Nexus 5 and Mercedes SAPv3

Post by jason71 » Thu Nov 07, 2013 4:33 pm


 
Posts: 4081
Joined: Wed Mar 23, 2011 4:12 pm

Re: Google Nexus 5 and Mercedes SAPv3

Post by admin » Thu Nov 07, 2013 11:28 pm

If you really want to do me a favor you can send an Amazon gift card to may admin at ... mail address 8-)

 
Posts: 30
Joined: Mon Jun 06, 2011 10:10 pm

Re: Google Nexus 5 and Mercedes SAPv3

Post by Quentin » Fri Nov 22, 2013 8:29 pm

Hi Admin.

A small thank you is out by Amazon - late, but still in time for CyberMonday :). Sorry for the late response, I was quite busy the last days in office and too tired to take on the issue in the late evenings.

I updated today to the latest version. But I still have a problem / phenomenon...

1) if I try to connect, very often it disconnects right after it again... On the mobile phone rSAP still says it is connected and SIM is booked out... but car SAPv3 says it is not connected - at this point, only restart BT and/or reboot helps
2) If I start rSAP app and keep it in foreground (and turn off display), connecting and staying online works...

Next I will try the "Wake Lock" and "Keep active" options - I never used them before (on my Galaxy Nexus they were never necessary).

Best regards,
Quentin

 
Posts: 4081
Joined: Wed Mar 23, 2011 4:12 pm

Re: Google Nexus 5 and Mercedes SAPv3

Post by admin » Sat Nov 23, 2013 11:29 am

Hey, thanks a lot! I'll use that for the new Arcade Fire album :D

Please try to create a log of a stuck connection. Maybe this is a strange timing issue. The Bluetooth state is also "connected" in this case?

Next

Return to LG/Google Nexus 5

Who is online

Users browsing this forum: No registered users and 2 guests