It is currently Fri Nov 24, 2017 11:58 pm

rSAP for Android Forum

Support forum for Android rSAP App

Android 4.4.3 support

Discussions about running the rSAP app on the LG Nexus 5
 
Posts: 16
Joined: Tue Jun 10, 2014 8:53 am

Re: Android 4.4.3 support

Post by bernstein » Tue Jul 22, 2014 1:14 pm

has anyone tried to compile a special bluetooth module, like here : http://forum.xda-developers.com/google-nexus-5/general/custom-bluetooth-module-nexus-5-4-4-3-t2777406

 
Posts: 4039
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 4.4.3 support

Post by admin » Tue Jul 22, 2014 2:41 pm

Why do want to do that? It will surely not fix the rSAP issue.

Apart from that it should be no problem to build a new bluetooth.default.so file. It will take some time, because you'll have to prepare a Linux (Mac?) machine for compilation and then get the whole Android source tree.

 
Posts: 4
Joined: Fri Dec 06, 2013 1:50 pm

Re: Android 4.4.3 support

Post by moravec » Fri Jul 25, 2014 9:19 am

Can anybody share a link, or explain how to downgrade the radio image on 4.4.4 to have it working with rSAP again?
Thank you very much.
Chris

 
Posts: 4039
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 4.4.3 support

Post by admin » Sat Jul 26, 2014 10:40 pm

See here http://forum.xda-developers.com/google- ... s-t2514095 for a list of all Nexus 5 radio images. The link at the top also contains zip files which can be flashed with a custom recovery. Flashing NEXUS5_KOT49E_RADIO.zip should make rSAP work again.

The other possibility is to flash the img file in "fastboot" mode, which is a bit more complicated.

 
Posts: 4
Joined: Fri Dec 06, 2013 1:50 pm

Re: Android 4.4.3 support

Post by moravec » Mon Jul 28, 2014 12:15 am

Tks, just went back to 4.4.2 android, :D hope Google will enable it again. Or a LG phone could be the next one...

 
Posts: 15
Joined: Fri Dec 13, 2013 10:44 pm

Re: Android 4.4.3 support

Post by delicats » Tue Jul 29, 2014 6:31 pm

Hello admin & all,

I just by chance saw that there is another radio SW on the xda web site.

LPV79 (L Preview)
M8974A-2.0.50.2.08
AAAAANAZQ20500018
QUALCOMM Incorporated May 7 2014

Did anybody try this already with regrads to rSAP? Anybody knows if using this L preview radio in combination with the 4.4.4 release incorporates a significant risk to brick the phone???

cheers

dirk

 
Posts: 15
Joined: Fri Dec 13, 2013 10:44 pm

Re: Android 4.4.3 support

Post by delicats » Thu Aug 14, 2014 3:37 pm

Just one more observation:

As i unfortunately have been one of the first ones that observed the problem with android 4.4.3 and then downgraded to the 4.4.2 radio to make rsap work again I for a long time skipped the upgrade to 4.4.4.

With Android 4.4.3 and the 4.4.2 radio I obeserved, especially with LTE enabled, often an excessive power drain while the radio was turned off (!). This was also visible in the battery information in the settings menue by the high percentage of the 'phone idle' consumption.

About a week ago I had some time to install 4.4.4., again with the 4.4.2 radio and the effect of high power consumption was gone again.

So if you have still 4.4.3 and also some strange energy loss problems, try 4.4.4.

Cheers

Dirk

 
Posts: 12
Joined: Wed Nov 06, 2013 7:12 pm

Re: Android 4.4.3 support

Post by cimst » Sat Aug 30, 2014 10:23 pm

Hi all,

I recently found that I cannot use my Nexus 5 as mobile hotspot anymore. When I try to activate it, the menu point just shows "Error". I know that I used that function many times in the past, but cannot confirm that this is the case since I use the older baseband on Android 4.4.4.

Could one of you confirm whether mobile hotspot still works in that combination? Would be great.

Cheers,

 
Posts: 16
Joined: Tue Jun 10, 2014 8:53 am

Re: Android 4.4.3 support

Post by bernstein » Tue Nov 11, 2014 10:26 am

I have rooted the L-preview, installed the 4.4.2 Radio, but unfortunatly the app cannot find certail system-libs, and is asking if this is a compatible phone. I will try again when the "official" lollipop is availaible an report back.

lg
Bernhard

 
Posts: 4039
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 4.4.3 support

Post by admin » Tue Nov 11, 2014 1:51 pm

This is an SELinux problem. If you set it "permissive" everything works. Of course, this is no good solution. I hope I will be able to add the missing permission from within the installer app.

PreviousNext

Return to LG/Google Nexus 5

Who is online

Users browsing this forum: No registered users and 1 guest