It is currently Tue Nov 21, 2017 12:58 am

rSAP for Android Forum

Support forum for Android rSAP App

Nexus 5 RSAP with Audi MMI no connectivity

Discussions about running the rSAP app on the LG Nexus 5
 
Posts: 2
Joined: Wed Jan 29, 2014 10:23 pm

Nexus 5 RSAP with Audi MMI no connectivity

Post by pcartier » Sun Oct 26, 2014 1:34 pm

I wonder if anyone can help met get rSAP to work with my Audi.
The follooing ...
I purchased the RSAP app a while back, have successfully rooted my Nexus 5 (Chainsaw) and have Chainsaw's Super SU Pro (purchased) installed too. The reason I did this is because I wanted to be able to read incoming SMS messages on the screen for the MMI system in my Audi ... I have a 2012 Audi A5 Sportback 2.0 TDI 130kW (SLine edition).
I have not problems with Bluetooth phonebook retrieval etc .. .that all worked fine via the standard Bluetooth connection before I installed the rSAP app.
I have followed all the instructions but cannot get RSAP to work ...
The problem is that although I have the rSAP Active on all the time the "Bluetooth State" remains "Not connected" !
For the rest, my phone and my address book are all present and working in the Audi as they always did! But as I understand it SMS text messages will never work if RSAP is not connected.
I have tried several variations of "solutions" on this site ... the last ... a total reset was this:
In car Bluetooth
================
* ... deleted all external devices
* switched off "make discoverable"
On Phone
========
- unpaired (removed) Audi from Bluetooth on Nexus and restarted
- switched off discoverability and rSAP active in RSAP app
- Ran RSAP installation again and restarted (generic mode not Nexus 4 mode)

Then ...
Still on phone:
- Left Bluetooth discoverability in standard Settings -> Bluetooth menu to "Only visible to paired devices"
- Started RSAP-App and activated Bluetooth Visibility inside the RSAP application.
In car:
- Searched for phone from MMI ... "Discover ... "
- Accepted pairing from MMI side


Result: as stated above ... phone, phonebook all work but rSAP "Bluetooth State" remains "Not connected"

 
Posts: 4038
Joined: Wed Mar 23, 2011 4:12 pm

Re: Nexus 5 RSAP with Audi MMI no connectivity

Post by admin » Mon Oct 27, 2014 1:37 pm

First of all you need the proper phone option in your Audi. Once it was called "car phone", then "Audi connect", outside of Germany it seems to be called "Bluetooth high". If your Audi doesn't have this option, it can only use the "Handsfree" profile.

 
Posts: 2
Joined: Wed Jan 29, 2014 10:23 pm

Re: Nexus 5 RSAP with Audi MMI no connectivity

Post by pcartier » Thu Oct 30, 2014 12:54 pm

Thanks for clear reply ... it had to be something like this.
My Audi was imported from German so it is "Audi connect" .
But I do not have "Audi connect" installed !
I understand from an Audi info site that it is not possible to have Audi connect "post-installed" ... it has to be purchased as an option and built into the car when they make it.
But I don't really accept this! ...
Does anyone perhaps know if there is another kind of workaround/hack to get the necessary Bluetooth functionality?
...
(just before I run off and buy another Audi :-) )


Return to LG/Google Nexus 5

Who is online

Users browsing this forum: No registered users and 1 guest