It is currently Tue Nov 21, 2017 1:02 am

rSAP for Android Forum

Support forum for Android rSAP App

Android 5.1

Discussions about running the rSAP app on the LG Nexus 5
 
Posts: 43
Joined: Sun May 20, 2012 8:51 pm

Re: Android 5.1

Post by klik » Fri May 15, 2015 7:40 am

Hi Admin,

rSAP works fine with Nexus 5 CM12.1/ElementalX kernel (baseband 1.0.25.0.23) and Audi S3 8P (RNS-E + rSAP in armrest).
However, after disconnecting from the car a reboot is required to successfully reconnect. Otherwise it connects in non rSAP mode.
Is there a way to overcome this?

thank you

 
Posts: 4038
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 5.1

Post by admin » Sat May 16, 2015 4:34 pm

I have no idea why it would do that. Maybe the reconnect plugin helps viewtopic.php?f=62&t=1115?

 
Posts: 43
Joined: Sun May 20, 2012 8:51 pm

Re: Android 5.1

Post by klik » Sat May 16, 2015 8:54 pm

Thank you, I will try it.

 
Posts: 43
Joined: Sun May 20, 2012 8:51 pm

Re: Android 5.1

Post by klik » Mon May 18, 2015 10:40 am

I tried it but unfortunately same thing.

 
Posts: 4038
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 5.1

Post by admin » Mon May 18, 2015 5:27 pm

Can you check if it works when you manually start the rSAP app before the second connection attempt? Maybe the rSAP Bluetooth service gets killed and doesn't restart. Is the icon visible in the notification bar?

 
Posts: 43
Joined: Sun May 20, 2012 8:51 pm

Re: Android 5.1

Post by klik » Mon May 18, 2015 6:49 pm

I tried what you suggested and managed to re-connect at random. Most of the time disconnecting and reconnecting took me to non rsap mode. The icon is visible on the notification bar but opening the rsap app bluetooth state shows error (attached photo)
Pulling out the rsap cradle and reconnecting rsap working. I have attached a log file for your review.
thank you for your kind attention
regards
Attachments
Screenshot_2015-05-18-19-15-04.png
screenshot of rsap error
Screenshot_2015-05-18-19-15-04.png (63.92 KiB) Viewed 813 times
rsap_log_main.rar
Log file
(6.08 KiB) Downloaded 56 times

 
Posts: 4038
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 5.1

Post by admin » Tue May 19, 2015 2:31 pm

Please try to delete the file /system/lib/hw/bluetooth.msm8974.so. It was installed by the rSAP installer.

If this doesn't help, your ROM seems to have a serious bug in the Bluetooth system.

 
Posts: 2
Joined: Mon Jun 01, 2015 10:56 am

Re: Android 5.1

Post by boelkstoff » Mon Jun 01, 2015 11:07 am

Hello,
I am also runnign CM12.1 nightlies on my Nexus 5.
But I dont get it to work with my VW Premium FSE in a Passat.

@klik: What have you done to get it work?
I installed the software with root and then tried to connect.
Also the test with the SIM Status is failing.

What about the baseband? How can i check it and how can I upgrade/downgrade?

I will attach a log in the next days.

Thanks a lot

 
Posts: 4038
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 5.1

Post by admin » Mon Jun 01, 2015 7:45 pm

You can check the baseband version in Android settings. rSAP will not work with a 2.x baseband version.
Here is a link to flashable files for the 1.0.25.0.23 baseband: http://forum.xda-developers.com/google- ... s-t2514095
Download the zip file and flash it with the custom recovery or download the img and flash it in fastboot mode.

 
Posts: 2
Joined: Mon Jun 01, 2015 10:56 am

Re: Android 5.1

Post by boelkstoff » Tue Jun 02, 2015 3:26 pm

Hello admin,

thanks a lot for your help.
I downgraded baseband and now everything is working.

So I can confirm, Nexus 5 with CM 12.1 nightly your app is working. Incl. Adressbook.
Thanks a lot

PreviousNext

Return to LG/Google Nexus 5

Who is online

Users browsing this forum: No registered users and 1 guest