It is currently Mon Dec 11, 2017 10:44 pm

rSAP for Android Forum

Support forum for Android rSAP App

Problems with Samsung rSAP

Discussions about running the rSAP app on the Samsung Note 3
 
Posts: 5
Joined: Sun Apr 27, 2014 3:13 pm

Problems with Samsung rSAP

Post by apow » Sun Apr 27, 2014 3:24 pm

Exactly the same problem with Samsung Note 3 (Android 4.4) and VW Premium (VW Passat 2010).

Using Samsung rSAP, here is the problem:
- after the initial paring, no luck trying to connect
- turns out the connection can be established after switching Bluetooth off and on again
- after a few minutes, the established connection dies anyway
- the only way to re-connect is via the Bluetooth off/on switch trick above

Installing the trial phonebook app did not help, any more advice would be much appreciated!

 
Posts: 4043
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 4.3 RSAP Golf Mk7 2014

Post by admin » Mon Apr 28, 2014 7:39 am

It looks like Samsung once more ruined rSAP. If you manage to create a "HCI snoop" log from within the Android developer settings I may be able to find out what goes wrong, although I don't think this information will help fix the problem. But it seems that even the HCI log is not working properly.

Guess you have to wait for a firmware update, or try my app, although I'm currently not sure if it will help.

 
Posts: 5
Joined: Sun Apr 27, 2014 3:13 pm

Re: Android 4.3 RSAP Golf Mk7 2014

Post by apow » Mon May 05, 2014 7:55 am

Thanks for your reply.

The good news:
- I purchased your Phonebook app and was able to sync without problems
- while established, the connection now seems to persist (perhaps due to the recent samsung update).

The bad news:
- still not able to connect without first turning bluetooth off and then on again.

HCI snoop log attached, would be appreciative if you could take a look.
Attachments
log.zip
(56.26 KiB) Downloaded 89 times

 
Posts: 4043
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 4.3 RSAP Golf Mk7 2014

Post by admin » Wed May 07, 2014 9:26 pm

Did you try to connect while the log was active and it did not work? 8 Seconds after log start a normal session is started which lasts about 17 minutes. I could not find anything unusual.

 
Posts: 5
Joined: Sun Apr 27, 2014 3:13 pm

Re: Android 4.3 RSAP Golf Mk7 2014

Post by apow » Thu May 08, 2014 7:40 am

The process was:
- I turned on the HCI logging
- after starting the car, it was trying to connect with the phone -- indefinitely
- I turned Bluetooth off, the car said "no connection to phone" and stop the connection process
- I turned Bluetooth on and initiated connection manually via the car interface ("connect to device")
- with this approach, the connection was established and everything seemed to work properly

 
Posts: 4043
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 4.3 RSAP Golf Mk7 2014

Post by admin » Thu May 08, 2014 9:40 am

Hmm... Can you please try again and this time note the time (on the phone) when you do something?

Did you already try a different SIM card? Maybe your problems are caused by your card.

 
Posts: 5
Joined: Sun Apr 27, 2014 3:13 pm

Re: Android 4.3 RSAP Golf Mk7 2014

Post by apow » Fri May 09, 2014 11:11 am

Sure, the new log attached.
Also tried with a different SIM card, got the same result.
Attachments
log.zip
(126.92 KiB) Downloaded 64 times

 
Posts: 4043
Joined: Wed Mar 23, 2011 4:12 pm

Re: Android 4.3 RSAP Golf Mk7 2014

Post by admin » Fri May 09, 2014 6:26 pm

While the connection hangs there is no connection with the car in the log, not even a connection attempt. There are lots of unknown HCI commands, but I'm not sure if this is the root of the problem. This may be a low level Bluetooth problem on your phone.

I don't know what you can do about it. If there is no firmware update which fixes it you may think of automatically switching off/on Bluetooth with a tool by some clever trigger, e.g. same time every day. The "Tasker" app can do this, maybe others, too.

 
Posts: 5
Joined: Sun Apr 27, 2014 3:13 pm

Re: Problems with Samsung rSAP

Post by apow » Fri May 09, 2014 9:09 pm

>>While the connection hangs there is no connection
>>with the car in the log, not even a connection attempt
I see. A bit confusing, as at the same time the phone shows ongoing rsim connection in notifications center. Does look like some weird samsung thing that hopefully will be addressed in a future update.

Anyway, thanks much for your support and suggestions!


Return to Samsung Note 3

Who is online

Users browsing this forum: No registered users and 1 guest