Page 5 of 6

Re: LG Nexus 5X

Posted: Sun Feb 07, 2016 7:09 pm
by admin
Finally bought me a Nexus 5X and found out that my 64 bit system files caused a crash. Verison 2.5.7 of the installer app fixes this. With my app rSAP now works on the Nexus 5X ;)

I took a quick look at the Google rSAP: it hangs when the car requests the end of the connection. After that the phone is no longer usable until you reboot it.

Re: LG Nexus 5X

Posted: Sat Feb 13, 2016 9:50 am
by dosen
Do I understand you, that rsap is working with your app on the Nexus 5x ? Do I have to root the phone therefore?

Re: LG Nexus 5X

Posted: Sat Feb 13, 2016 12:03 pm
by admin
Yes, it works, and yes, you have to root your phone.

Re: LG Nexus 5X

Posted: Tue Feb 23, 2016 2:49 pm
by langers2k
admin wrote:I took a quick look at the Google rSAP: it hangs when the car requests the end of the connection. After that the phone is no longer usable until you reboot it.
I've never had to reboot the phone, just toggle bluetooth off/on once bluetooth disconnects (possible via various apps).

It's worked on all releases for the 5X so far without fail :)

Re: LG Nexus 5X

Posted: Thu Mar 17, 2016 10:17 pm
by fents
Hi

Finaly got around to trying rsap app on my Nexus 5X and hate to say it but having problems.

I get a "Socket Connection Error" under sim state and a "Fatal Error Connect_REQ" when I run a check.

And yes I have tried and done everything right, I am running MHC19J Update.

Any Ideas???

Thanks

Re: LG Nexus 5X

Posted: Fri Mar 18, 2016 8:58 am
by admin
Did you allow root access for the rSAP app? Do you use SuperSU?

Re: LG Nexus 5X

Posted: Fri Mar 18, 2016 10:56 am
by fents
Yep and Yep

Re: LG Nexus 5X

Posted: Fri Mar 18, 2016 12:42 pm
by admin
This looks like a crash somewhere. Something must have changed with the latest update.

Re: LG Nexus 5X

Posted: Fri Mar 18, 2016 8:35 pm
by fents
Sigh!! Why can't they just make something that works?

Let me know how you get on.

Thanks

Re: LG Nexus 5X

Posted: Fri Mar 18, 2016 10:19 pm
by admin
I found the reason: Qualcomm (or Google) removed some "high-level" functions from their libraries with the latest update. I already have a working version with "low-level" functions. I'm also trying to find a fix for the Nexus 6, I hope I can release both in a single update, so it may take one more day.