It is currently Tue Dec 11, 2018 7:43 am

rSAP for Android Forum

Support forum for Android rSAP App

Experience with my DHD

Discussions about running the rSAP app on the HTC Desire HD
 
Posts: 17
Joined: Wed Apr 06, 2011 11:46 am

Experience with my DHD

Post by cnow » Wed Apr 06, 2011 12:00 pm

repost from XDA:

Hello,

Last two days I tested Version 0.8.1. of the rSAP App.

Phone: HTC Desire HD
ROM: LeeDroid 2.2.2
Car: VW Passat EZ03/2010
BT Kit: VW Premium with RNS510 (rSAP)

I was aware of the problems with the DHD. So far this was the result:

Yesterday 05.04.11:
- 1st connect: Pairing failed (DHD discovered, Pin number accepted, then connection failed)
- 2nd connect: Pairing succeeded (Pairing completed, called my mailbox, but phonebook snyc was endless - waited 30min...)
- did a reset, then connected to Premium UHV again and voilá - Phonebook synced (about 5min for round about 200 contacts)
- now I started a test drive and unfortunately the stability of the network connection was very low. After seconds network connection was lost and never got back.
- now I did several resets with the same results.

Today 06.04.11:
- installed the new system files
- result is the same:
-- phone and car-kit initiates booth ok but with no network connection (displayed in MFA+ and RNS510)
-- after little time network connection shows up (all signal bars) and drops seconds later again and never comes back
- curious: I can turn off bluetooth in my DHD and connection to car-kit is still alive ;-)
- had to to a reset to use rSAP again

I made Logs which I will send to the developer. Unfortunately HCI-Logs don't work with my DHD. They are always 0kb small...

Thank you for your hard work and hopefully the DHD will be fully supported soon!

with best regards,
cnow

 
Posts: 1
Joined: Mon Apr 11, 2011 4:30 pm

Re: Experience with my DHD

Post by Try4Ce » Mon Apr 11, 2011 4:32 pm

Thanks for your insight on the DHD Problem and the logs you sent the developer.
My dad has freshly bought the DHD and has a VW Premium System in his car. He cannot use his DHD for it, obviously, and I am really hoping that this will work one day as intended.
Seems like its kind of a bitch to get a proper driver ready, but I keep my hopes up for this project. 8-)

 
Posts: 17
Joined: Wed Apr 06, 2011 11:46 am

Re: Experience with my DHD

Post by cnow » Tue Apr 12, 2011 8:10 am

Hello admin,
yesterday I tried Cyanogen 7.0 final on my DHD with the new system files provided on the HP. With this ROM I didn't get the "SDP record fix failed" like in my favourite LeeDroid ROM. According to the FAQ this has to do with the different bluetooth stack in Sense-ROMs (...like LeeDroid).

After pairing my DHD with the VW Premium car-kit the connection was stable and I could do several calls! The problem with disconnecting and the need for reboot was still there - as expected.

I recommend to change the compatibility matrix for DHD and LeeDroid v2.2.2 ROM. The combination VW Premium <> DHD is not really working (at least for me) as you can connect and sync phonebook but can't use the phone.
(btw. Radio Version is: 12.28e.60.140fU_26.04.02.17_M2)

best regards,
cnow

PS: Now I'll try the CoreDroid ROM with Sense included and therefor behavior should be the same as with LeeDroid...
Last edited by cnow on Tue Apr 12, 2011 8:40 am, edited 2 times in total.

 
Posts: 17
Joined: Wed Apr 06, 2011 11:46 am

Re: Experience with my DHD

Post by cnow » Tue Apr 12, 2011 8:35 am

Hello,
I tried CoreDroid 4.9 and it worked like Cyanogen, but with "SDP record fix failed". I could do phone calls also at the second and third reboot/reconnect. Maybe it has to do with Gingerbread? Next I'll try LeeDroid 2.3.
cnow

 
Posts: 3
Joined: Sat Apr 21, 2012 10:17 pm

Re: Experience with my DHD

Post by jollycity » Sun Apr 22, 2012 8:13 am

I tried the trial app yesterday with my vw Bluetooth and RNS 510. I have the Bluetooth that has both standard and premium. Everything connectsfine, phonebook transfers ok. After around 30 seconds, the network drops. In settings, the network options are greyed out and I am told that the radio has been disabled. If I switch to standard Bluetooth, the signal comes back straight away. I can't send a log as I am a newb here.

 
Posts: 4090
Joined: Wed Mar 23, 2011 4:12 pm

Re: Experience with my DHD

Post by admin » Sun Apr 22, 2012 12:57 pm

You mean the phone's mobile network is gone? That's normal behaviour in rSAP/Premium mode.

 
Posts: 3
Joined: Sat Apr 21, 2012 10:17 pm

Re: Experience with my DHD

Post by jollycity » Sun Apr 22, 2012 2:40 pm

Yes, there is no mobile network so I can't make or receive calls. I don't just mean on the phone, I mean on the handsfree too.
rns 510
Image




maxidot display
Image




app state
Image




mobile network disabled?
Image




Software
Image]

 
Posts: 4090
Joined: Wed Mar 23, 2011 4:12 pm

Re: Experience with my DHD

Post by admin » Sun Apr 22, 2012 10:09 pm

That's strange... So rSAP works but the car phone cannot log into the mobile network. First guess is that the antenna is not connected... If not, please mail me a "main" log.

 
Posts: 3
Joined: Sat Apr 21, 2012 10:17 pm

Re: Experience with my DHD

Post by jollycity » Sat May 05, 2012 4:10 pm

Thank you. When I checked my bluetooth module, the GSM aerial hadn't been fitted. It took me all of 2 minutes to sort this out. Thanks again. I now have the full version and premium features working. Just need to decide carefully now which phone to get when my contract renews soon.


Return to HTC Desire HD

Who is online

Users browsing this forum: No registered users and 1 guest