Page 1 of 1

Problem with libhtc_ril.so

Posted: Tue May 17, 2011 6:36 pm
by bouya_k
Hello

Since I update this rom : http://forum.xda-developers.com/showthr ... ?t=1042986

Asa I apply the libhtc_ril.so in the /system/lib and reboot

I don't have any phone network....

If I put back the original my phone network is back...

very strange...

Re: Problem with libhtc.so

Posted: Tue May 17, 2011 6:48 pm
by admin
You must not simply replace the original libhtc_ril.so but rename it exactly to libhtc_ril.orig.so and then copy the "rSAP" version of the lib to /system/lib. That's what the install zips do.

Re: Problem with libhtc_ril.so

Posted: Tue May 17, 2011 7:06 pm
by bouya_k
Thanks for the quick reply

I forgot to rename the file.... oops

The install zip doesn't work for me don't why.... strange

Thanks for your help

Fantastic tools that you did, you avoid me to change my car lol

Re: Problem with libhtc_ril.so

Posted: Sun Jun 19, 2011 5:03 pm
by raddon
as i've tried several times, with all "how to install rSAP" steps/methods mentioned here and a bunch of different roms and got no succes with the "libhtc_ril.so" and even lost telefone network connection, i've finaly gut succes on my DHD CM7 by:

load the" terminal emulator" app from Market to my DHD
load "root expolrer" app from Market to my DHD

opened "terminal emulator", wrote:

Code: Select all

su
mount -o remount ,rw /system
chmod 777 /system/lib
left "Terminal Emulator with backarrow on keyboard and
started "Root explorer" navigated to "System\lib" renamed "libhtc_ril.so" into "libhtc_ril.orig.so"

Downloaded the"rsap-installation.zip" from here. Extracted the file ""libhtc_ril.new.so" from the Ziparchive subfolder "lib" and renamed it to "libhtc_ril.so" Put this "libhtc_ril.so" to any place on my SDCARD and put it with copy and paste by "Root explorer" to System/lib.

Mayby very complicated but it worked...

...now have to check out what my Porsche PCM is complaining..;-)