It is currently Wed Dec 13, 2017 3:37 am

rSAP for Android Forum

Support forum for Android rSAP App

Oneplus One

Discussions about running the rSAP app on OnePlus phones
 
Posts: 4043
Joined: Wed Mar 23, 2011 4:12 pm

Re: Oneplus One

Post by admin » Wed Apr 08, 2015 1:34 pm

To make sure, please repeat the test after installing the system files with the above installer app (viewtopic.php?f=12&t=1379#p8273). If it says "access denied" it's still the same problem.

 
Posts: 24
Joined: Sat Jan 05, 2013 4:55 pm

Re: Oneplus One

Post by hanno » Wed Apr 08, 2015 2:08 pm

please see screenshot attached.

just to make sure, I got you the right way ... Just installed the installer app from your link above, reinstalled the system files and rebooted the phone. Didn't say "access denied", but still doesn't look right.

... although, I didn't get an error message regarding the "StatusChange", but rather "ConnectionStatus".

Is this one step further or do I have to test it in my car?
Attachments
Screenshot_2015-04-08-14-03-04.png
Screenshot
Screenshot_2015-04-08-14-03-04.png (59.11 KiB) Viewed 1399 times

 
Posts: 4043
Joined: Wed Mar 23, 2011 4:12 pm

Re: Oneplus One

Post by admin » Mon Apr 13, 2015 11:59 am

Did you turn on Bluetooth before running the SIM check?

 
Posts: 24
Joined: Sat Jan 05, 2013 4:55 pm

Re: Oneplus One

Post by hanno » Mon Apr 13, 2015 1:03 pm

I've got bluetooth turned on all the time ... also, there is the bluetooth sign on the upper notification bar.

 
Posts: 4043
Joined: Wed Mar 23, 2011 4:12 pm

Re: Oneplus One

Post by admin » Mon Apr 13, 2015 1:13 pm

Does the app show a problem with the system files? Did you grant root access for the rSAP app?

 
Posts: 24
Joined: Sat Jan 05, 2013 4:55 pm

Re: Oneplus One

Post by hanno » Mon Apr 13, 2015 1:28 pm

No problem with the sstem files, however - now - I got an "bluetooth error" ... root access is granted, also rechecked the settings in "SuperSU".

Attached both screenshots. Thanks again for your help
Attachments
Screenshot_2015-04-13-13-25-20.png
Screenshot 2
Screenshot_2015-04-13-13-25-20.png (65.36 KiB) Viewed 1367 times
Screenshot_2015-04-13-13-25-13.png
Screenshot 1
Screenshot_2015-04-13-13-25-13.png (59.57 KiB) Viewed 1367 times

 
Posts: 4043
Joined: Wed Mar 23, 2011 4:12 pm

Re: Oneplus One

Post by admin » Mon Apr 13, 2015 3:20 pm

Hmm... Difficult to find out what's going on...

The "Fatal error" in your first test happens when something really basic goes wrong. The "qmi_error = 0x0000" tells that at least the communication to the system files works, but the communication to the SIM card does not. I have the same message currently on my Xperia Z3 with Lollipop and I hope I can fix that soon. Maybe that fix also works for the OnePlus One.

For the Bluetooth error I currently have no explanation. This also happens after a reboot? Can you please try and manually delete the file /system/lib/hw/bluetooth.x.so, where x is not (!) "default"?

 
Posts: 24
Joined: Sat Jan 05, 2013 4:55 pm

Re: Oneplus One

Post by hanno » Tue Apr 14, 2015 3:09 pm

Disappointment rises ... just flashed to CM12s, still the same "qmi_error=0x0000" error.

I also opened a ticket at the one plus support ... do you have a detailed description of the error, I can forward to them? What exactly does this error message mean "communication to the SIM card"?

 
Posts: 4043
Joined: Wed Mar 23, 2011 4:12 pm

Re: Oneplus One

Post by admin » Tue Apr 14, 2015 10:32 pm

rSAP is not a specified feature of the OnePlus One, so it"s not a bug. You can only politely ask them to add the feature ;)

The basic problem is that there is no official way to access the SIM card in Android. I use undocumented interfaces which may change with every new firmware release or the functions may even be switched off completely, which happened with the Nexus 5. I guess the new release has the same changes as the recent Sony Xperia updates. That's why you get qmi-error 0 instead of "access denied". I don't think there is a high probability that they enabled rSAP in the new release.

 
Posts: 3
Joined: Mon Jul 04, 2016 7:13 pm

Re: Oneplus One

Post by ceemjay » Mon Jul 04, 2016 7:15 pm

Is this working or ever going to work on a OnePlus One?

ceemjay

PreviousNext

Return to OnePlus

Who is online

Users browsing this forum: No registered users and 1 guest