Firmware 4.1.2 - Samsung rsap not working

Discussions about running the rSAP app on the Samsung Galaxy S II
realist42
Posts: 22
Joined: Tue May 21, 2013 2:46 pm

Firmware 4.1.2 - Samsung rsap not working

Post by realist42 » Tue May 21, 2013 4:19 pm

Hi,

I have a SGS2, currently on 4.1.2 stock ROM, and I have a 2006 VW with premium handsfree. I used the rSAP app when i was on 4.0.3 and the Samsung rsap support was absent in the phone, it worked great, so I have the app. I then moved to 4.0.4 and back to the Samsung rsap stack which has worked fine until now. For, what must be error in packaging, the rsap support for my car is now broken in the 4.1.2 ROM, as in it will do the rsap connection request, but then it disconnects again.

I strongly suspect that this something to do with the phone book transfer, but trying the Phonebook app sadly made no difference at all

My question is that I would like to know what can I do to get the rsap application and daemon to take the place of the stock Samsung bits? Not really very keen on a custom rom just to get around this problem.

I did downgrade the phone back to 4.0.4 just to prove the point and then it all started to work again.

Oddly enough the SGS3 that we also have at home works like a treat in the same car, so we know that Samsung can make it work with 4.1.2. Also, I much prefer 4.1.2 to 4.0.x, it just seems to work better, so not so keen on going back to 4.0.4 or 4.0.3.

Any suggestions would be greatly appreciated.

J.

realist42
Posts: 22
Joined: Tue May 21, 2013 2:46 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by realist42 » Tue May 21, 2013 4:32 pm

Ahh, one more more bit that might be relevant...

I have not, nor do really want to root the phone, I was hoping to do this without using the installer app (which I believe can disable the samsung rsap stack). I think the rsap-install off the SD card still works, correct me if I am wrong.

J.

realist42
Posts: 22
Joined: Tue May 21, 2013 2:46 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by realist42 » Wed May 22, 2013 6:31 pm

Hi,

Was hoping for a quick reply...

In short, as the Samsung stack is broken, what options do I have rSAP Android? or will I have to live with the fact that it will not work unless I go back to 4.0.4?

Regards,
J.

admin
Site Admin
Posts: 4132
Joined: Wed Mar 23, 2011 4:12 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by admin » Sat May 25, 2013 9:35 am

If it is a problem with the phonebook you may try my phonebook app. You can check if it is the phonebook problem when you remove and redo the Bluetooth pairing and don't allow access to the phonebook. If the connection is stable the phonebook transfer causes the trouble.

If the rSAP connection aborts because of a text message you need my rSAP app. You can still install the system files without root if you use the zip files made for Android 4.1.

realist42
Posts: 22
Joined: Tue May 21, 2013 2:46 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by realist42 » Thu May 30, 2013 12:32 am

admin wrote:If it is a problem with the phonebook you may try my phonebook app. You can check if it is the phonebook problem when you remove and redo the Bluetooth pairing and don't allow access to the phonebook. If the connection is stable the phonebook transfer causes the trouble.

If the rSAP connection aborts because of a text message you need my rSAP app. You can still install the system files without root if you use the zip files made for Android 4.1.
Hi,

Well, the car has the 'old style' pairing, so there is no authorisation for the phonebook as it only uses the SIM phone book. I did try the phone book application and it sadly made no difference at all. I think the only route is to 'root' the phone (looking at doing a root without custom kernel) and then run the installer app.

Will I be able to 'disable' the Samsung rsap daemon with the installer app? if not I am a bit stuck again.

Regards,

J.

admin
Site Admin
Posts: 4132
Joined: Wed Mar 23, 2011 4:12 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by admin » Thu May 30, 2013 9:42 am

The installer app does disable the Samsung rSAP.

It's strange that my phonebook app didn't work. A 2006 Premium should support the IrMC profile which my app provides. Maybe you have to redo the Bluetooth pairing. I still don't understand what information the Premium box stores, and when and why it requests the phonebook from the phone, or doesn't.

realist42
Posts: 22
Joined: Tue May 21, 2013 2:46 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by realist42 » Fri May 31, 2013 2:41 pm

admin wrote:The installer app does disable the Samsung rSAP.

It's strange that my phonebook app didn't work. A 2006 Premium should support the IrMC profile which my app provides. Maybe you have to redo the Bluetooth pairing. I still don't understand what information the Premium box stores, and when and why it requests the phonebook from the phone, or doesn't.
I have no idea what Samsung has done with the 4.2.1 on the SGS2 and rsap. It just did not work with the older car, but works with the newer car (also rsap) It would pair, but then stall and disconnect.

I have now rooted the phone and installed the rsap app with the installer, and confirmed to disable the Samsung stack. We shall see what happens when I try it with the older car. Worked really well with the newer car, felt like it connected with more confidence (and seems happier with rsap, could be a little hit and miss with the Samsung stack if you got rsap of HFP)

btw, any chance of getting the icon at the top of the screen to be optional when there is no connection active? I don't have enough room there as it is, and now I have another icon there...

regards,

J.

realist42
Posts: 22
Joined: Tue May 21, 2013 2:46 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by realist42 » Fri May 31, 2013 11:58 pm

admin wrote:The installer app does disable the Samsung rSAP.

It's strange that my phonebook app didn't work. A 2006 Premium should support the IrMC profile which my app provides. Maybe you have to redo the Bluetooth pairing. I still don't understand what information the Premium box stores, and when and why it requests the phonebook from the phone, or doesn't.

I need some help here! I have got the rsap application, a rooted phone, the phonebook app, and still it does not work. Same phone with ICS 4.0.4 work fine in the same car. As I wrote before, it pairs, connects and stays connected for a few seconds and then disconnects.

It does not seem to matter what I do, tried both the phonebook profiles, still disconnects, have not got a clue to what is going on here.

Can this be fixed? What do I need to provide so that we can see what is going on?

Will now have to dust off an old Nokia to have in the car for now - not ideal...

Regards,

J.

admin
Site Admin
Posts: 4132
Joined: Wed Mar 23, 2011 4:12 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by admin » Sat Jun 01, 2013 2:48 pm

Please mail me a "main" log from the rSAP app.

realist42
Posts: 22
Joined: Tue May 21, 2013 2:46 pm

Re: Firmware 4.1.2 - Samsung rsap not working

Post by realist42 » Sat Jun 01, 2013 7:36 pm

admin wrote:Please mail me a "main" log from the rSAP app.
Hi,

Email sent.

Thanks,

J.

Post Reply

Return to “Samsung Galaxy S II I9100”