Xiaomi Redmi Note 3

Discussions about running the rSAP app on Xiaomi phones
Site Admin
Joined:Wed Mar 23, 2011 4:12 pm
Xiaomi Redmi Note 3

Post by admin » Sun Mar 05, 2017 7:29 pm

I received a mail from a user who successfully enabled rSAP on his Redmi Note 3:
It took a lot of messing about! I obviously had to root the phone.

Then your installation app, both the Generic Mark III and Generic Mark II methods failed.

I got a windows box, and put the QPST on. I had to put the phone into diag mode using the adb shell in root mode.

I tried to transfer the file and windows crashed due to an exception. Hapenned about three times.

I then obtained QXDM. Set factory mode. Rebooted. the setting *DID NOT* seem to persist, when I read it back.

*BUT* my phone was strange and reading as "no sim card entered", even though there was a SIM. I set factory mode again without rebooting.

I transferred the settings file in QPST. It worked!

I rebooted phone. Used rsap installation Mark III. Same error. Used Mark II. It showed an error also, but then on the installation ap, part 3 saying "CHECK" I pressed "Re-Try" and is worked, and showed Connect to SIM.

Then went on to Main RSAP app. It crashed. Loaded again, and it worked.

I tested by connecting to VW premium car phone and all functions working, including internet, SMS and phone book.

Post Reply

Return to “Xiaomi”